Skip to content


Subversion checkout URL

You can clone with
Download ZIP
Solita Developer Blog
CSS JavaScript HTML Ruby Shell
Pull request Compare This branch is 306 commits behind solita:master.
Fetching latest commit...
Cannot retrieve the latest commit at this time.
Failed to load latest commit information.


Here are some developer-oriented thoughts from Solita Oy. Our stories have not yet been told. More will come. Stay tuned at


We use a combination of Jekyll and Github Pages to run the site.

If you want to write a post, here's how:

  1. Fork this project to yourself (upper right corner)
    • You need a Github account to do this
  2. Clone your own fork to your computer (git clone)
  3. Add your author info to _config.yml
  4. Write a new post under the _posts folder using Markdown, look at other posts for example of what to write there
  5. If you have Ruby and Jekyll, preview your post locally (instructions below)
  6. Create a pull request at
    • Choose your fork on the right
    • Write some info about the post
  7. Wait for comments and publish!

Previewing posts

You need Ruby and Jekyll if you want to preview your posts locally on the blog. If you're fine with just previewing the Markdown, you can use a Markdown preview script, like this one for Sublime Text.

Installing Ruby

For Windows, download & install the latest Ruby 1.9.x and Development Kit from
Note: Make sure to tick the checkbox "Add Ruby to PATH" (or something). You can also try:

For OSX(/Linux), use the instructions below. If you have installed Xcode, you might have ruby (1.9.2 or something like that) already. No guarantinees about this working with that so use RVM

  1. \curl -L | bash -s stable --ruby=1.9.3
  2. fork this repo
  3. go to your working copy of
  4. rvm use 1.9.3
  5. verify that 1.9.3 used by ruby -v (On linux you might need to fix gnome-termina:
  6. gem install bundler
  7. Run bundle install for depencies
  8. Make sure the installation succeeds
  9. Type in: jekyll serve --watch
  10. Open browser to: http://localhost:4000/

Also seems to be working with Ruby 2.0.0p0/247


For development, you need Ruby and Jekyll. If you want to tweak the CSS, you need Compass. Also, if you want to make stuff easier, install foreman.

  1. Install Ruby (above)
  2. To install Jekyll, Compass and foreman, type into a command prompt or terminal:
    gem install jekyll compass foreman rdiscount
  3. Make sure the install succeeds
  4. Go to your cloned copy of
  5. Type in: foreman start
  6. Jekyll and Compass should start!

Technology stack

/dev/solita is built using all the hippiest hip technologies available:

git, Github Pages, Ruby, Jekyll, Markdown, Sass, Compass, foreman, jQuery, Gravatar, disqus, Google Analytics, AddThis
Something went wrong with that request. Please try again.