Skip to content
Branch: master
Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
..
Failed to load latest commit information.
scripts
src
test
.env
.gitignore
LICENSE
README.md
package-lock.json
package.json
tsconfig.json
tslint.json

README.md

npm

buidler-truffle4

Buidler plugin for integration with TruffleContract from Truffle 4

What

This plugin brings to Buidler TruffleContracts from Truffle 4. With it you can call contract() and artifacts.require() like you normally would with Truffle. Interact with your contracts with a familiar API from tasks, scripts and tests.

Additionally, you can migrate your contracts to Solidity 5 without needing to migrate your tests to Truffle 5.

Required plugins

This plugin requires buidler-web3-legacy as a prerequisite.

Installation

npm install @nomiclabs/buidler-truffle4 @nomiclabs/buidler-web3-legacy web3@^0.20.7

And add the following statement to your buidler.config.js:

usePlugin("@nomiclabs/buidler-truffle4");

Tasks

This plugin creates no additional tasks.

Environment extensions

An instance of TruffleEnvironmentArtifacts is injected into env.artifacts and the method contract() is injected into the global scope for using in tests.

Usage

There are no additional steps you need to take for this plugin to work.

Install it, run npx buidler test and your Truffle tests should run with no need to make any modifications.

You can’t perform that action at this time.