Skip to content
Branch: master
Find file History
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
..
Failed to load latest commit information.
scripts
src
test
.env
.gitignore
LICENSE
README.md
package.json
tsconfig.json
tslint.json

README.md

buidler-vyper

npm

Buidler plugin to develop smart contracts with Vyper.

What

This plugin adds support for Vyper to Buidler. Once installed, Vyper contracts can be compiled by running the compile task.

This plugin generates the same artifact format as the built-in Solidity compiler, so that it can be used in conjunction with all other plugins.

The Vyper compiler is run using the official Docker images.

Installation

First, you have to install Docker Desktop by following its Get Started guide.

Then, you need to install the plugin by running

npm install @nomiclabs/buidler-vyper

And add the following statement to your buidler.config.js:

usePlugin("@nomiclabs/buidler-vyper");

Required plugins

No plugins dependencies.

Tasks

This plugin creates no additional tasks.

Environment extensions

This plugin does not extend the Buidler Runtime Environment.

Configuration

This plugin adds an optional vyper entry to Buidler's config, which lets you specify the Vyper version to use. If no version is given, the latest one on Docker Hub will be used.

This is an example of how to set it:

module.exports = {
  vyper: {
    version: "0.1.0b9"
  }
};

Usage

There are no additional steps you need to take for this plugin to work.

TypeScript support

You need to add this to your tsconfig.json's files array: "node_modules/@nomiclabs/buidler-vyper/src/type-extensions.d.ts"

You can’t perform that action at this time.