Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Fix node engine in package.json #128

Merged
merged 1 commit into from

3 participants

@Dignifiedquire

This is the correct specification of the node engine, otherwise it gets ignored by npm. Please also fix this in the 0.5.7 version so we can do installs depending on the node version.

@Dignifiedquire Dignifiedquire referenced this pull request in karma-runner/karma
Closed

Logger issues. Again. #448

@vojtajina vojtajina commented on the diff
package.json
@@ -17,7 +17,9 @@
"bugs": {
"url": "http://github.com/nomiddlename/log4js-node/issues"
},
- "engines": [ "node >=0.10" ],
+ "engines": {
+ "node": ">=0.10"

you should set it to ~0.10

if node 0.12 brings an incompatible change that breaks log4js, this version won't work with node 0.12 anymore (but NPM will allow installing it) and therefore you will release a new patched version, where you define engine ~0.10 || ~0.12.

if you wanna allow unstable versions of node, you can do ~0.10 || ~0.11

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@nomiddlename nomiddlename merged commit 0544342 into nomiddlename:master

1 check passed

Details default The Travis build passed
@vojtajina

@nomiddlename check my comment please

Can you please push 0.5.8 release to the npm (for people using node 0.8) and specify engine to ~0.8 ? I can send you pull request if it helps... (current 0.5.7 says it works with node 0.10, but it does not).

@vojtajina

Can you also change the engine to ~0.10 or ~0.10 || ~0.11 and push a new release (0.6.1) to npm ? Currently log4js is breaking people to install Karma on 0.8 node, releasing 0.5.8 and 0.6.1 would solve this.

Thanks @nomiddlename - let me know if I can help you...

@nomiddlename
Owner

Will do. Thanks for the change. I've published 0.5.8 (with engines.node = "~0.6||~0.8") and 0.6.1 (with engines.node = "~0.10").

@vojtajina

Awesome! Thanks for such a quick fix!

@nomiddlename
Owner

No worries. I was wondering why I was getting so many people trying to use log4js@0.6.0 with node 0.8, but I was too stupid to check the package.json. Sorry for causing so many problems.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Apr 1, 2013
  1. @Dignifiedquire
This page is out of date. Refresh to see the latest.
Showing with 3 additions and 1 deletion.
  1. +3 −1 package.json
View
4 package.json
@@ -17,7 +17,9 @@
"bugs": {
"url": "http://github.com/nomiddlename/log4js-node/issues"
},
- "engines": [ "node >=0.10" ],
+ "engines": {
+ "node": ">=0.10"

you should set it to ~0.10

if node 0.12 brings an incompatible change that breaks log4js, this version won't work with node 0.12 anymore (but NPM will allow installing it) and therefore you will release a new patched version, where you define engine ~0.10 || ~0.12.

if you wanna allow unstable versions of node, you can do ~0.10 || ~0.11

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+ },
"scripts": {
"test": "vows"
},
Something went wrong with that request. Please try again.