Skip to content
This repository
README.md

EasySIMBLEasySIMBL

Changes from original SIMBL

  • OS X 10.7, 10.8, 10.9
  • Reads plugins from ~/Library/Application Support/SIMBL/Plugins only.
  • Never reads plugins from /Library/Application Support/SIMBL/Plugins.
  • Support sandboxed application.
  • Support resumed on login application.
  • Drag and Drop install to /Applications or ~/Applications folder, no uninstaller required.
  • Change injection method.
  • Install plugins(.bundle) from Finder.
  • NEW Support injecting plugins into background process LSBackgroundOnly=1 and agent process LSUIElement=1, if plugin has explicitly targeting application bundle identifier (not *. e.g. com.apple.appkit.xpc.openAndSavePanelService, com.apple.dock or com.apple.security.pboxd).

How to install

  1. Download EasySIMBL-1.6.zip (2013/11/25 updated)
  2. Extract and move EasySIMBL.app into /Applications or ~/Applications.
  3. Launch EasySIMBL.app and check Use SIMBL, then quit EasySIMBL.app.

How to upgrade

  1. Move older EasySIMBL.app into Trash.
  2. Move newer EasySIMBL.app into /Applications or ~/Applications.
  3. Launch EasySIMBL.app and check Use SIMBL, then quit EasySIMBL.app.

How to uninstall

  1. Launch EasySIMBL.app then uncheck Use SIMBL, then quit EasySIMBL.app.
  2. Move EasySIMBL.app into Trash.

Tested combinations of OS X and applications

If you want to provide another plugin's information, please use a wiki. Thanks.

This list includes combinations which I tested on my Mac.

PowerboxInjector is not compatible with EasySIMBL. Sorry, the reason exists on EasySIMBL side.

License

Copyright 2003-2009, Mike Solomon <mas63@cornell.edu>
SIMBL is released under the GNU General Public License v2.
http://www.opensource.org/licenses/gpl-2.0.php

Copyright 2012, hetima
EasySIMBL is released under the GNU General Public License v2.
http://www.opensource.org/licenses/gpl-2.0.php

Copyright 2012, Norio Nomura
EasySIMBL is released under the GNU General Public License v2.
http://www.opensource.org/licenses/gpl-2.0.php
Something went wrong with that request. Please try again.