Skip to content
Browse files

Make incompatibility with Rails 3.2 explicit in gemspec.

  • Loading branch information...
1 parent e7f84ba commit ee036fe50ecd39d38d3c8825b0af1d7c524488b9 @norman committed
Showing with 4 additions and 3 deletions.
  1. +2 −1 README.md
  2. +1 −1 friendly_id.gemspec
  3. +1 −1 lib/friendly_id/version.rb
View
3 README.md
@@ -21,7 +21,8 @@ please see the [FriendlyId Guide](https://github.com/norman/friendly_id/blob/3.x
## Compatibility
-FriendlyId 3.3.0 is compatible with Active Record 3.0 and 3.1.
+FriendlyId 3.3.0 is compatible with Active Record 3.0 and 3.1. For Rails 3.2
+and higher, please use FriendlyId 4.x.
If you are still on Rails 2.3, please use FriendlyId 3.2.x.
View
2 friendly_id.gemspec
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.version = FriendlyId::Version::STRING
s.add_dependency "babosa", "~> 0.3.0"
- s.add_development_dependency "activerecord", "~> 3.0"
+ s.add_development_dependency "activerecord", "< 3.2"
s.add_development_dependency "mocha", "~> 0.9"
s.add_development_dependency "sqlite3", "~> 1.3"
s.add_development_dependency "rake", "~> 0.9.2"
View
2 lib/friendly_id/version.rb
@@ -3,7 +3,7 @@ module Version
MAJOR = 3
MINOR = 3
TINY = 1
- BUILD = nil
+ BUILD = 1
STRING = [MAJOR, MINOR, TINY, BUILD].compact.join('.')
end
end

2 comments on commit ee036fe

@parndt
Collaborator

I suspected such.

@parndt
Collaborator

Here's how I made it compatible! (in my friendly_id_globalize3 version)

parndt@63417be

Please sign in to comment.
Something went wrong with that request. Please try again.