Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Call super in LazySuite to access _removed_tests variable #811

Merged
merged 1 commit into from May 20, 2014

Conversation

@rkuska
Copy link
Contributor

commented May 19, 2014

I have encountered the issue #759 while building billiard with python 3.4, as mentioned in my comment.

@jszakmeister jszakmeister modified the milestones: 1.3.2, 1.3.4 May 19, 2014
@rkuska

This comment has been minimized.

Copy link
Contributor Author

commented May 20, 2014

@jszakmeister

This comment has been minimized.

Copy link
Contributor

commented May 20, 2014

Nice catch! Thanks for the PR!

jszakmeister added a commit that referenced this pull request May 20, 2014
Call super in LazySuite to access _removed_tests variable
@jszakmeister jszakmeister merged commit cfc24b3 into nose-devs:master May 20, 2014
1 check passed
1 check passed
continuous-integration/travis-ci The Travis CI build passed
Details
@brianmay brianmay referenced this pull request Aug 10, 2014
emulbreh pushed a commit to emulbreh/lymph that referenced this pull request Nov 19, 2014
balabit-sync pushed a commit to balabit-deps/balabit-os-6-nose that referenced this pull request Nov 19, 2018
nose (1.3.7-3) unstable; urgency=medium

  * Add a patch to fix test failures with Python 3.6 (closes: #880232).
  * Update Homepage field to use the new readthedocs.io domain.
  * Bump Standards-Version to 4.1.1, no changes needed.

nose (1.3.7-2) unstable; urgency=medium

  * Add a patch to make coverage plugin compatible with python-coverage 4.1
    (closes: #828224).
  * Bump Standards-Version to 3.9.8, no changes needed.

nose (1.3.7-1) unstable; urgency=medium

  [ Brian May ]
  * New upstream version.

  [ Dmitry Shachnev ]
  * Backport upstream commit that fixes tests failures with Python 3.5
    (closes: #811468).
  * Use HTTPS in Vcs-Git field and in debian/watch.
  * Override Lintian false-positive warning about missing source for
    unit_tests/support/doctest/noname_wrapped.not_pyc.

nose (1.3.6-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Update debian/watch to use pypi.debian.net redirector.
  * Bump debhelper compatibility level to 9.
  * Bump Standards-Version to 3.9.6, no changes needed.
  * Add John Szakmeister’s key to debian/upstream/signing-key.asc,
    and tell uscan to verify it via debian/watch.
  * Explicitly build-depend on dh-python.

nose (1.3.4-2) unstable; urgency=medium

  * Change maintainer to the team.

nose (1.3.4-1) unstable; urgency=medium

  * New upstream bugfix release.
  * debian/patches/fix_constructor: drop, applied upstream.
  * Update my email address.
  * Update debian/copyright.

nose (1.3.3-2) unstable; urgency=low

  * Add patch to make sure we call super constructor for LazySuite. Without
    this, tests fail under Python3.4 as _removed_tests not defined. Patch
    copied from nose-devs/nose#811 which has been
    included upstream in git. Closes: #757640.

nose (1.3.3-1) unstable; urgency=medium

  * New upstream bugfix release.

nose (1.3.2-1) unstable; urgency=medium

  * New upstream bugfix release.
  * Drop patches applied upstream (for issues 780, 782, 783 and 788).
  * Refresh disable-unstable-tests patch.

nose (1.3.1-2) unstable; urgency=medium

  * Backport a patch (issue780) to fix UnboundMethod regression with
    Python 3.
  * Add myself to Uploaders.

nose (1.3.1-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Drop d/patches/issue759, applied in the new version.
  * Add three new patches (issue782, issue783 and issue788) to fix
    various test failures (closes: #741750).
  * Disable one more unstable test.
  * Remove unit_tests/support/doctest/noname_wrapped.not_pyc in
    clean target.

nose (1.3.0-3) unstable; urgency=medium

  * Team upload.
  * d/patches/issue759: Add a patch from Barry Warsaw to fix FTBFS
    with Python 3.4. 
  * d/control: Bump Standards-Version to 3.9.5, no changes needed.
  * Rebuild closes: #730749.

nose (1.3.0-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * debian/control (Build-Depends): Added libjs-jquery-hotkeys,
    libjs-jquery-isonscreen and libjs-jquery-tablesorter (closes: #726695).

nose (1.3.0-2) unstable; urgency=low

  * Team upload.
  * Upload to unstable.

  [ Jakub Wilk ]
  * Use canonical URIs for Vcs-* fields.

  [ Dmitry Shachnev ]
  * Rebuild without python2.6 (closes: #675753, #707897).
  * Drop nosetests-3.x scripts. There is no easy way to provide these
    scripts for all supported Python 3 versions, and there are other
    ways to do the same thing (like running python3.x -m nose).
  * Install a manpage for nosetests-2.7.
  * Update the Homepage: field.

nose (1.3.0-1) experimental; urgency=low

  [ Dmitry Shachnev ]
  * Team upload.
  * New upstream release (closes: #675554).
    - Fixes exceptions in tests generator (closes: #663465, thanks to
      Jakub Wilk for the bug report).
    - Provides __main__.py, which allows using nose as "python3 -m nose"
      (thanks to Stefano Rivera for the patch).
  * Build-depend on python-coverage (for the test suite).
  * Bump Standards-Version to 3.9.4, no changes needed.
  * Disable some unstable tests (in multiprocessing module) to make the
    package not FTBFS.
  * Run the tests for Python 3.x during build.
  * debian/patches/manpage-formatting: dropped, the issue is properly
    fixed upstream.
  * debian/rules: disable HTTP traffic during build.
  * Refresh other patches.
  * Update debian/clean.

  [ Charlie Smotherman ]
  * Removed myself from uploaders in debian/control

nose (1.1.2-3) unstable; urgency=low

  * Team upload.
  * Rebuild with python3-defaults 3.2.3~rc1-2, to generate correct
    python3:Depends.
  * Bumped Standards Version to 3.9.3 (no changes needed).

nose (1.1.2-2) unstable; urgency=low

  * Team upload.
  * Add versioned Breaks & Replaces in python-nose-doc, for moved doc-base
    file.

nose (1.1.2-1) unstable; urgency=low

  [ Charlie Smotherman ]
  * New Upstream release. Closes: #646394
  * Switched to source format 3.0 (quilt).
  * Package builds twice in a row now. Closes: #608678
  * Increased debhelper compat level to 7.
  * Migrated from debian/pyversions to X-P-V
  * Migrated debian/copyright to DEP5.
  * Pointed debian/watch at PyPI
  * Use dh7 tiny rules. Bumped debhelper B-D to >= 7.0.50~
  * Use dh_python2. Closes: #631406
    - Bump python B-D to python-all (>= 2.6.6-3~)
  * Use dh_sphinxdoc. Closes: #636079
  * Build python 3 package. Closes: #604038, #647920
    - B-D on python3-all, python3-setuptools.
    - Break documentation into a separate python-nose-doc package.
  * Add myself to Uploaders.
  * Install manpages from debian/rules

  [ Stefano Rivera ]
  * Team upload.
  * Remove Google Analytics js from documentation template.
  * Clean correctly after unit tests.
  * Wrap and sort long fields in debian/control.
  * Respect nocheck in DEB_BUILD_OPTIONS.
  * Ensure seteup.py doesn't use distribute_setup.
  * Rework python 3 package, not to use alternatives.
  * Fix shebangs to match script names.
  * Provide rst symlink in python-nose-doc.

nose (1.0.0-1) unstable; urgency=low

  * Team upload.

  [ Jakub Wilk ]
  * Fix watch file.

  [ Piotr Ożarowski ]
  * New upstream release (closes: #608677)
    - adds Python 2.7 (closes: #608679)
  * Remove build dir in clean target

nose (0.11.1-1) unstable; urgency=low

  * New upstream release
  * Documentation is now included
  * debian/control
    - build-depend on python-sphinx
    - bump build-dependency on python-dev to >= 2.5.4-1~
    - bump standards to 3.8.1, no changes necessary
    - added dependency to libjs-jquery
  * debian/rules
    - addded --install-layout=deb to DEB_PYTHON_INSTALL_ARGS
    - build the documentation using Sphinx
  * debian/doc-base
    - added doc-base file to register documentation

nose (0.10.4-2) unstable; urgency=low

  [ Stephan Peijnik ]
  * Upload to unstable
  * Added misc:Depends to fix lintian warning

nose (0.10.4-1) experimental; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - switch Vcs-Browser field to viewsvn

  [ Piotr Ożarowski ]
  * New upstream release

nose (0.10.3-1) unstable; urgency=low

  [Torsten Marek]
  * New upstream release (Closes: #461994)
  * debian/control
    - bump standards version to 3.8.0, no changes necessary
    - add suggestions for python-coverage (Closes: #457053)
    - change dependency on python-setuptools into 
      python-pkg-resources (Closes: #468719)
    - added myself to uploaders

  [Gustavo Noronha Silva]
  * debian/control:
    - remove -1 from build-dep on setuptools

nose (0.10.1-1) unstable; urgency=low

  [ Sandro Tosi ]
  * debian/control
    - uniforming Vcs-Browser field

  [ Ondrej Certik ]
  * New upstream release
  * Standards version upgraded to 3.7.3

nose (0.10.0-1) unstable; urgency=low

  [ Piotr Ożarowski ]
  * Vcs-Browser and Homepage fields added
  * XS-Vcs-Svn field renamed to Vcs-Svn

  [ Gustavo Noronha Silva ]
  * New upstream release (Closes: #449072)

nose (0.9.3-1) unstable; urgency=low

  * New upstream release

nose (0.9.2-3) unstable; urgency=low

  [ Piotr Ożarowski ]
  * New python-support handles egg's directory name correctly
    - bump python-support required version
    - remove mv part from debian/rules
    (Closes: #423978)

nose (0.9.2-2) unstable; urgency=low

  * Uploading to unstable

nose (0.9.2-1) experimental; urgency=low

  * New upstream release
  * debian/rules:
  - remove the incorrect path in which upstream is installing
    the manpage
  * debian/manpages, debian/nosetests.1:
  - have the upstream manpage be installed, instead of the one I provide
    (it is the one upstream is providing now, but updated)

nose (0.9.1-1) experimental; urgency=low

  [ Piotr Ozarowski ]
  * New upstream release
  * debian/control:
  - moved python-dev to Build-Depends: (to satisfy lintian)
  - added XS-Vcs-Svn field
  * debian/rules:
  - simplified a little bit (`pyversions -vd' instead of sed)
  * Added debian/watch file
  * Bumped debhelper compatibility from 4 to 5

nose (0.9.0-2) unstable; urgency=low

  * debian/control:
  - added python-setuptools to Depends (Closes: #395287)
  - added XS-Python-Version
  * debian/docs:
  - added, now install README.txt documentation (addresses #395289)
  * debian/examples:
  - added; install the examples provided, as well
  * debian/nosetests.1, debian/manpages:
  - added; manpage generated by help2man and adapted to add some important
    information (Closes: #395289)

nose (0.9.0-1) unstable; urgency=low

  * Initial Release (Closes: #366786)
  - thanks to Arnaud Fontaine <arnaud@andesi.org> for implementing the new
    python policy
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.