Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Bring dependencies up to current versions.

This involved taking out rcov, as it isn't happy on Ruby 1.9 and later.
  • Loading branch information...
commit 793b65cbb09b6c435ba2b27e4a90d1a4fcc55537 1 parent c111d12
@notahat authored
View
56 Gemfile.lock
@@ -6,33 +6,34 @@ PATH
GEM
remote: http://rubygems.org/
specs:
- activemodel (3.0.9)
- activesupport (= 3.0.9)
- builder (~> 2.1.2)
- i18n (~> 0.5.0)
- activerecord (3.0.9)
- activemodel (= 3.0.9)
- activesupport (= 3.0.9)
- arel (~> 2.0.10)
- tzinfo (~> 0.3.23)
- activesupport (3.0.9)
- arel (2.0.10)
- builder (2.1.2)
- diff-lcs (1.1.2)
- i18n (0.5.0)
- mysql (2.8.1)
- rake (0.9.2)
- rcov (0.9.9)
- rdoc (3.6.1)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- tzinfo (0.3.28)
+ activemodel (3.2.12)
+ activesupport (= 3.2.12)
+ builder (~> 3.0.0)
+ activerecord (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ arel (~> 3.0.2)
+ tzinfo (~> 0.3.29)
+ activesupport (3.2.12)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ arel (3.0.2)
+ builder (3.0.4)
+ diff-lcs (1.2.1)
+ i18n (0.6.4)
+ multi_json (1.6.1)
+ mysql (2.9.1)
+ rake (10.0.3)
+ rdoc (4.0.0)
+ rspec (2.13.0)
+ rspec-core (~> 2.13.0)
+ rspec-expectations (~> 2.13.0)
+ rspec-mocks (~> 2.13.0)
+ rspec-core (2.13.0)
+ rspec-expectations (2.13.0)
+ diff-lcs (>= 1.1.3, < 2.0)
+ rspec-mocks (2.13.0)
+ tzinfo (0.3.35)
PLATFORMS
ruby
@@ -42,6 +43,5 @@ DEPENDENCIES
machinist!
mysql
rake
- rcov
rdoc
rspec
View
9 Rakefile
@@ -7,15 +7,10 @@ require 'rspec/core/rake_task'
require 'rdoc/task'
-RSpec::Core::RakeTask.new
-
-RSpec::Core::RakeTask.new(:rcov) do |spec|
- spec.rcov = true
- spec.rcov_opts = ['--exclude', 'spec', '--exclude', '.rvm']
-end
+RSpec::Core::RakeTask.new(:spec)
desc 'Run the specs.'
-task :default => :rcov
+task :default => :spec
RDoc::Task.new(:rdoc) do |rdoc|
View
1  machinist.gemspec
@@ -21,7 +21,6 @@ Gem::Specification.new do |s|
s.add_development_dependency "activerecord"
s.add_development_dependency "mysql"
s.add_development_dependency "rake"
- s.add_development_dependency "rcov"
s.add_development_dependency "rspec"
s.add_development_dependency "rdoc"
end
View
8 spec/machinable_spec.rb
@@ -60,7 +60,7 @@ class Comment
it "makes array attributes from the blueprint" do
MachinableSpecs::Comment.blueprint { }
- MachinableSpecs::Post.blueprint do
+ MachinableSpecs::Post.blueprint do
comments(3) { MachinableSpecs::Comment.make }
end
@@ -75,14 +75,14 @@ class Comment
it "fails without a blueprint" do
expect do
MachinableSpecs::Post.make
- end.should raise_error(Machinist::NoBlueprintError) do |exception|
+ end.to raise_error(Machinist::NoBlueprintError) do |exception|
exception.klass.should == MachinableSpecs::Post
exception.name.should == :master
end
expect do
MachinableSpecs::Post.make(:some_name)
- end.should raise_error(Machinist::NoBlueprintError) do |exception|
+ end.to raise_error(Machinist::NoBlueprintError) do |exception|
exception.klass.should == MachinableSpecs::Post
exception.name.should == :some_name
end
@@ -93,7 +93,7 @@ class Comment
expect do
MachinableSpecs::Post.make!
- end.should raise_error(Machinist::BlueprintCantSaveError) do |exception|
+ end.to raise_error(Machinist::BlueprintCantSaveError) do |exception|
exception.blueprint.klass.should == MachinableSpecs::Post
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.