New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

songs not listed #27

Closed
sedrubal opened this Issue Aug 13, 2014 · 14 comments

Comments

Projects
None yet
7 participants
@sedrubal

sedrubal commented Aug 13, 2014

I detected, that some songs are not listet in the database-view of ympd, but the database of mpd contains them, because ncmpc lists them. Unfortunately I did't see something special on this songs...

@archphile

This comment has been minimized.

Show comment
Hide comment
@archphile

archphile Sep 25, 2014

Contributor

I have the exact same problem with various flacs albums of my collection. When I browse the database, I click on an album directory and it shows empty. If I click add the whole directory it's ok and the songs appear in queue. In addition I can normally see the files in directories using MPdroid or other clients.

Please feel free to ask me for anything additional that will help you debug.

Contributor

archphile commented Sep 25, 2014

I have the exact same problem with various flacs albums of my collection. When I browse the database, I click on an album directory and it shows empty. If I click add the whole directory it's ok and the songs appear in queue. In addition I can normally see the files in directories using MPdroid or other clients.

Please feel free to ask me for anything additional that will help you debug.

@notandy

This comment has been minimized.

Show comment
Hide comment
@notandy

notandy Oct 19, 2014

Owner

Could you send me some information about the filenames and tags of the affected files? I couldn't reproduce it yet

Owner

notandy commented Oct 19, 2014

Could you send me some information about the filenames and tags of the affected files? I couldn't reproduce it yet

@notandy notandy added the bug label Oct 19, 2014

@sedrubal

This comment has been minimized.

Show comment
Hide comment
@sedrubal

sedrubal Oct 19, 2014

ok. For example there is a folder called "Hardwell". It contains 138 songs.
One song is like this:

Artist:  HARDWELL
Titel:     Adrian Lux ft. Rebecca & Fiona - Boy (Hardwell Remix)
Length:     2:23
Genre:     Progressive House
Path:       Hardwell/Adrian Lux ft. Rebecca & Fiona - Boy (Hardwell Remix).mp3
MPD Statistic
Artist Count:      630
Album Count:         853
Songs Count:        9887

sedrubal commented Oct 19, 2014

ok. For example there is a folder called "Hardwell". It contains 138 songs.
One song is like this:

Artist:  HARDWELL
Titel:     Adrian Lux ft. Rebecca & Fiona - Boy (Hardwell Remix)
Length:     2:23
Genre:     Progressive House
Path:       Hardwell/Adrian Lux ft. Rebecca & Fiona - Boy (Hardwell Remix).mp3
MPD Statistic
Artist Count:      630
Album Count:         853
Songs Count:        9887
@archphile

This comment has been minimized.

Show comment
Hide comment
@archphile

archphile Oct 20, 2014

Contributor

Hi,

the latest issue was with the following:

file name : 01 Brando.flac
directory: Scott Walker + Sunn O))) - Soused [2014] CD FLAC
tags: http://s17.postimg.org/zefkkht73/bug_1.jpg

Contributor

archphile commented Oct 20, 2014

Hi,

the latest issue was with the following:

file name : 01 Brando.flac
directory: Scott Walker + Sunn O))) - Soused [2014] CD FLAC
tags: http://s17.postimg.org/zefkkht73/bug_1.jpg

@yjokawa

This comment has been minimized.

Show comment
Hide comment
@yjokawa

yjokawa Sep 23, 2015

Hi,

First of all, thank you for this great mpd client!

I also have the same trouble.
When I first build ympd in March, the binary works completely.
However, when I build it in August, the bug appeared.
I suppose that mongoose 5.6 causes this problem, but I don't have any direct evidence.

Regards,
yjo

yjokawa commented Sep 23, 2015

Hi,

First of all, thank you for this great mpd client!

I also have the same trouble.
When I first build ympd in March, the binary works completely.
However, when I build it in August, the bug appeared.
I suppose that mongoose 5.6 causes this problem, but I don't have any direct evidence.

Regards,
yjo

@yjokawa

This comment has been minimized.

Show comment
Hide comment
@yjokawa

yjokawa Oct 15, 2015

When returning no song info, mpd gives the following error:
MPD mpd_send_list_meta: Not found
MPD connection failed.

yjokawa commented Oct 15, 2015

When returning no song info, mpd gives the following error:
MPD mpd_send_list_meta: Not found
MPD connection failed.

@tedigh

This comment has been minimized.

Show comment
Hide comment
@tedigh

tedigh Jan 2, 2016

Hi,
In my case, the folders / songs those contain "comma" in their names are missing.
I find the calls of strtok() in mpd_client.c do wrong with them.
The removal of 4ba3e0b seems to be one of the solutions.

tedigh commented Jan 2, 2016

Hi,
In my case, the folders / songs those contain "comma" in their names are missing.
I find the calls of strtok() in mpd_client.c do wrong with them.
The removal of 4ba3e0b seems to be one of the solutions.

@LordMyschkin

This comment has been minimized.

Show comment
Hide comment
@LordMyschkin

LordMyschkin Jan 2, 2016

thats exactly the same bug I filed under issue #106.
Commas may be part of the problem, but I also do not see a file named "01_-johannes_brahms-_klavierkonzert_nr._1-_maestoso.mp3"
If you want to reproduce the problem, I send you the link to my library - or some of my files...
Please let me know if I can be of any help - or point me to the best IDE to debug ympd on the raspberry....

LordMyschkin commented Jan 2, 2016

thats exactly the same bug I filed under issue #106.
Commas may be part of the problem, but I also do not see a file named "01_-johannes_brahms-_klavierkonzert_nr._1-_maestoso.mp3"
If you want to reproduce the problem, I send you the link to my library - or some of my files...
Please let me know if I can be of any help - or point me to the best IDE to debug ympd on the raspberry....

@tedigh

This comment has been minimized.

Show comment
Hide comment
@tedigh

tedigh Jan 3, 2016

I found at least some special characters in the directory names cause this issue.
try the both.
sed -i 's/codeURI/codeURIComponent/g' htdocs/js/mpd.js
revert 4ba3e0b (merge conflict needs to be resolved by hand)

tedigh commented Jan 3, 2016

I found at least some special characters in the directory names cause this issue.
try the both.
sed -i 's/codeURI/codeURIComponent/g' htdocs/js/mpd.js
revert 4ba3e0b (merge conflict needs to be resolved by hand)

@SuperBFG7

This comment has been minimized.

Show comment
Hide comment
@SuperBFG7

SuperBFG7 Jan 25, 2016

Contributor

I just ran into this as well and created a fix: #116
it's already included in my fork

Contributor

SuperBFG7 commented Jan 25, 2016

I just ran into this as well and created a fix: #116
it's already included in my fork

@LordMyschkin

This comment has been minimized.

Show comment
Hide comment
@LordMyschkin

LordMyschkin Jan 25, 2016

Thank you so much, @SuperBFG7; it works finally!

LordMyschkin commented Jan 25, 2016

Thank you so much, @SuperBFG7; it works finally!

@SuperBFG7

This comment has been minimized.

Show comment
Hide comment
@SuperBFG7

SuperBFG7 Jan 25, 2016

Contributor

You're welcome. Thanks @tedigh for pointing me in the right direction.

Contributor

SuperBFG7 commented Jan 25, 2016

You're welcome. Thanks @tedigh for pointing me in the right direction.

@yjokawa

This comment has been minimized.

Show comment
Hide comment
@yjokawa

yjokawa Jan 26, 2016

Thank you, SuperBFG7!
I also succeeded. Your fix works very well!!

yjokawa commented Jan 26, 2016

Thank you, SuperBFG7!
I also succeeded. Your fix works very well!!

@notandy

This comment has been minimized.

Show comment
Hide comment
@notandy

notandy Feb 14, 2016

Owner

should be fixed now

Owner

notandy commented Feb 14, 2016

should be fixed now

@notandy notandy closed this Feb 14, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment