Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

USB sound stutters #2

Closed
danbuntu opened this issue Oct 20, 2013 · 4 comments

Comments

@danbuntu
Copy link

@danbuntu danbuntu commented Oct 20, 2013

I've been using this firmware as per texy's instructions at: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=45&t=48967

I've got got his screen working fine but I have an issue with a usb sound card that I'm using - it stutters and sounds get very distorted at times.
If I run the official pi firmware at
https://github.com/raspberrypi/firmware
then all the sound issues go away - although obviously the screen then stops working.

Is there a way that I can combine the sound fixes in the official firmware with your firmware or any other possible fix to this?

@notro

This comment has been minimized.

Copy link
Owner

@notro notro commented Oct 20, 2013

Do you have sound problems without the FBTFT driver loaded?

If No, try to use DMA with FBTFT (lowers the CPU load). See: https://github.com/notro/fbtft/wiki#install

sudo modprobe fbtft dma

If Yes, try the vanilla firmware that the latest FBTFT release is based on, to see if the problem exists there

sudo rpi-update fadc4cbd10d8144d301c894dd9975704db6206fa

I'm planning to make a new release when 3.10.y becomes the main kernel: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=29&t=55711

@danbuntu

This comment has been minimized.

Copy link
Author

@danbuntu danbuntu commented Oct 22, 2013

I tried with dma loaded and the same problem exists - Looking at htop output it's not high cpu that's causing the issue - although a lower cpu load will be useful for the next stage of the project so thanks for pointing that out.

The second command just error-ed.
So I followed the link to your forum post and did 'sudo BRANCH=next rpi-update' This fixed the sound issues but then broke the screen - a 'modprobe fbtft' fails.

Is there something that I can do abut this or is it just a case of being patient and waiting for the next release?

@notro

This comment has been minimized.

Copy link
Owner

@notro notro commented Nov 1, 2013

I had to rewrite my build scripts, so I commited a new release while at it.

3.10 is also made available in the 'next' branch:

sudo REPO_URI=https://github.com/notro/rpi-firmware BRANCH=next rpi-update
@notro

This comment has been minimized.

Copy link
Owner

@notro notro commented Dec 14, 2013

Do you still have problems?

@notro notro closed this Dec 26, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.