Skip to content

fb_graph issue moving from 0.14.2 to 0.14.4 #17

Closed
minter opened this Issue Mar 5, 2012 · 2 comments

2 participants

@minter
minter commented Mar 5, 2012

In our fb_graph app, when we upgraded from rack-oauth2 0.14.2 to 0.14.4, all Facebook requests would fail with an uncaught 400 exception.

The failures were coming from trying to auth via cookies:

    fb_auth = FbGraph::Auth.new(FACEBOOK_APP_ID, FACEBOOK_APP_SECRET)
    fb_auth.client # => Rack::OAuth2::Client

    fb_auth.from_cookie(cookies)

Any known changes that would be causing this? Reverting back to 0.14.2 fixed the problem.

@nov
Owner
nov commented Mar 5, 2012

Update fb_graph too please.

@minter
minter commented Mar 5, 2012

Weird - I thought I had tried that and it didn't work, but it's working now. Maybe there was something up with fb_graph 2.4.3?

Anyway, thanks! I appreciate the help!

@minter minter closed this Mar 5, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.