Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add react-hot-loader as peer dependency #1040

Merged
merged 1 commit into from Feb 22, 2019

Conversation

Projects
None yet
2 participants
@dpikt
Copy link
Contributor

dpikt commented Feb 22, 2019

React-static doesn't work out of the box without react-hot-loader, so it should be listed as a peerDependency.

Description

I added the version that's included in the template projects to the peerDependency field of react-static.

Changes/Tasks

  • Changed code

Motivation and Context

This will make it easier to add react-static to a project without using a template, increasing flexibility.

Types of changes

  • Refactoring/add tests (refactoring or adding test which isn't a fix or add a feature)
  • Bug fix (non-breaking change which fixes an issue)
  • New feature (non-breaking change which adds functionality)
  • Breaking change (fix or feature that would cause existing functionality to not work as expected)

Checklist:

  • My change requires a change to the documentation.
    • I have updated the documentation accordingly.
  • My changes have tests around them
@tannerlinsley

This comment has been minimized.

Copy link
Collaborator

tannerlinsley commented Feb 22, 2019

I like it!

@tannerlinsley tannerlinsley merged commit 2865b5a into nozzle:master Feb 22, 2019

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
deploy/netlify Deploy preview ready!
Details

@dpikt dpikt deleted the LaunchPadLab:hot-loader-peer-dep branch Feb 22, 2019

leekad added a commit to leekad/react-static that referenced this pull request Feb 25, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.