Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update target framework to 2.2 #1073

Closed
wants to merge 1 commit into from

Conversation

@joshfriend
Copy link

joshfriend commented Oct 8, 2019

When trying to use 3.0.1 in my project (i was using 2.2.4 previously), I get this error:

MyApp.csproj: [NU1202] Package Npgsql.EntityFrameworkCore.PostgreSQL 3.0.1 is not compatible with netcoreapp2.2 (.NETCoreApp,Version=v2.2). Package Npgsql.EntityFrameworkCore.PostgreSQL 3.0.1 supports: netstandard2.1 (.NETStandard,Version=v2.1)

I am using dotnet core 2.2.401 on macOS

@YohDeadfall

This comment has been minimized.

Copy link
Member

YohDeadfall commented Oct 8, 2019

.NET Standard isn't the same as .NET Core. They are different frameworks. Speaking about EF Core 3.0 running on .NET Core 2.2, it isn't possible because EF Core requires .NET Standard 2.1 at least while .NET Core is superset of .NET Standard 2.0.

@YohDeadfall YohDeadfall closed this Oct 8, 2019
@joshfriend joshfriend deleted the MichiganLabs:net-framework-target branch Oct 8, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.