Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Excel PowerQuery - 'Could not load file or assembly 'System.Memory, Version=4.0.1.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified.'" #2356

Closed
isosphere opened this Issue Mar 5, 2019 · 3 comments

Comments

Projects
None yet
3 participants
@isosphere
Copy link

isosphere commented Mar 5, 2019

Steps to reproduce

  1. Be PowerQuery user
  2. Have postgresql database (postgresql-11.2-1-windows-x64)
  3. Go to this website that tells you to install npgsql https://support.office.com/en-us/article/connect-to-a-postgresql-database-power-query-bf941e52-066f-4911-a41f-2493c39e69e4
  4. Install latest release (4.0.5) (used GAC install, maybe that's bad?)
  5. Try to get data
  6. Unable to connect, error pasted below

The issue

Details: "An error happened while reading data from the provider: 'Could not load file or assembly 'System.Memory, Version=4.0.1.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51' or one of its dependencies. The system cannot find the file specified.'"

Further technical details

Npgsql version: 4.0.5
PostgreSQL version: postgresql-11.2-1-windows-x64
Operating system: windows 10

Other details about my project setup:

@fleetside72

This comment has been minimized.

Copy link

fleetside72 commented Mar 8, 2019

I have the exact same issue scenario that popped up after install 4.0.5 only difference being I am targeting postgres on linux vm.

roji added a commit to roji/Npgsql that referenced this issue Mar 8, 2019

@roji

This comment has been minimized.

Copy link
Member

roji commented Mar 8, 2019

System.Memory is a new dependency that was indeed left out from the MSI installer... Have submitted a patch for this, which should be released with 4.0.6.

@roji roji self-assigned this Mar 8, 2019

@roji roji added the bug label Mar 8, 2019

@roji roji added this to the 4.0.6 milestone Mar 8, 2019

@roji roji closed this in #2361 Mar 8, 2019

roji added a commit that referenced this issue Mar 8, 2019

roji added a commit that referenced this issue Mar 8, 2019

Add System.Memory to MSI installer
Fixes #2356

(cherry picked from commit 327e4c8)
@isosphere

This comment has been minimized.

Copy link
Author

isosphere commented Mar 8, 2019

Thank you @roji!

If anyone else is having the same problem, I've installed 4.0.3 instead which appears to be prior to this dependency. The older version seems to be working fine for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.