Permalink
Browse files

You can't please everyone.

Don't try to be secure if it'll fail.

If someone really wants to encourage this all the time, then they can do
`npm config set unsafe-perm false` explicitly.

In the npm 1.0 future, it will probably require sudo for global
installing no matter what, and use this behavior for local installing.
Since so many people have npm installing in their home dir, requiring
sudo is causing more trouble than it's worth.
  • Loading branch information...
isaacs committed Feb 19, 2011
1 parent 31e4478 commit dae3259fd17866c189c5e8b3a7968f515b1af4ca
Showing with 1 addition and 0 deletions.
  1. +1 −0 lib/utils/default-config.js
@@ -50,6 +50,7 @@ module.exports =
|| process.platform === "cygwin"
|| !( process.getuid && process.setuid
&& process.getgid && process.setgid )
|| process.getuid() !== 0
, "update-dependents" : true
, usage : false
, user : "nobody"

0 comments on commit dae3259

Please sign in to comment.