Skip to content

@wraithgar wraithgar released this Oct 7, 2021 · 16 commits to latest since this release

v8.0.0 (2021-10-07)

The purpose of this release is to drop support for old node versions and
to remove support for require('npm'). There are no other breaking
changes.

BREAKING CHANGES

  • Drop support for node 10 and 11
  • Raise support ceiling in node 12 and 14 to LTS (^12.13.0/^14.15.0)
  • Drop support to require('npm')
  • Update subdependencies that also dropped node10 support

DEPENDENCIES

  • The following dependencies were updated to drop node10 support and
    update to the latest node-gyp
    • libnpmversion@2.0.1
    • pacote@12.0.0
    • libnpmpack@3.0.0
    • @npmcli/arborist@3.0.0
    • libnpmfund@2.0.0
    • libnpmexec@3.0.0
    • node-gyp@8.2.0
    • 8bd85cdae #3813 cli-columns@4.0.0
Assets 2