Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
193 lines (192 sloc) 4.717 kB
{
"version": "3.2.0",
"name": "npm",
"description": "a package manager for JavaScript",
"keywords": [
"install",
"modules",
"package manager",
"package.json"
],
"preferGlobal": true,
"config": {
"publishtest": false
},
"homepage": "https://docs.npmjs.com/",
"author": "Isaac Z. Schlueter <i@izs.me> (http://blog.izs.me)",
"repository": {
"type": "git",
"url": "https://github.com/npm/npm"
},
"bugs": {
"url": "http://github.com/npm/npm/issues"
},
"directories": {
"bin": "./bin",
"doc": "./doc",
"lib": "./lib",
"man": "./man"
},
"main": "./lib/npm.js",
"bin": "./bin/npm-cli.js",
"dependencies": {
"abbrev": "~1.0.7",
"ansicolors": "~0.3.2",
"ansistyles": "~0.1.3",
"aproba": "~1.0.1",
"archy": "~1.0.0",
"async-some": "~1.0.2",
"chownr": "0.0.2",
"cmd-shim": "~2.0.1",
"columnify": "~1.5.1",
"config-chain": "~1.1.9",
"dezalgo": "~1.0.3",
"editor": "~1.0.0",
"fs-vacuum": "~1.2.6",
"fs-write-stream-atomic": "~1.0.3",
"fstream": "~1.0.7",
"fstream-npm": "~1.0.4",
"glob": "~5.0.14",
"graceful-fs": "~4.1.2",
"has-unicode": "~1.0.0",
"hosted-git-info": "~2.1.4",
"iferr": "~0.1.5",
"inflight": "~1.0.4",
"inherits": "~2.0.1",
"ini": "~1.3.4",
"init-package-json": "~1.7.1",
"lockfile": "~1.0.1",
"lodash.clonedeep": "~3.0.1",
"lodash.union": "~3.1.0",
"lodash.uniq": "~3.2.2",
"lodash.without": "~3.2.1",
"mkdirp": "~0.5.1",
"node-gyp": "~2.0.2",
"nopt": "~3.0.3",
"normalize-git-url": "~3.0.1",
"normalize-package-data": "~2.3.1",
"npm-cache-filename": "~1.0.2",
"npm-install-checks": "~2.0.0",
"npm-package-arg": "~4.0.2",
"npm-registry-client": "~6.5.1",
"npm-user-validate": "~0.1.2",
"npmlog": "~1.2.1",
"once": "~1.3.2",
"opener": "~1.4.1",
"osenv": "~0.1.3",
"path-is-inside": "~1.0.0",
"read": "~1.0.6",
"read-installed": "~4.0.2",
"read-package-json": "~2.0.0",
"read-package-tree": "~5.1.0",
"realize-package-specifier": "~3.0.1",
"retry": "~0.6.1",
"rimraf": "~2.4.2",
"semver": "~5.0.1",
"sha": "~1.3.0",
"slide": "~1.1.6",
"sorted-object": "~1.0.0",
"tar": "~2.1.1",
"text-table": "~0.2.0",
"uid-number": "0.0.6",
"umask": "~1.1.0",
"unique-filename": "~1.0.0",
"unpipe": "~1.0.0",
"validate-npm-package-name": "~2.2.2",
"which": "~1.1.1",
"wrappy": "~1.0.1",
"write-file-atomic": "~1.1.2"
},
"bundleDependencies": [
"abbrev",
"ansicolors",
"ansistyles",
"aproba",
"archy",
"async-some",
"chownr",
"cmd-shim",
"columnify",
"config-chain",
"dezalgo",
"editor",
"fs-vacuum",
"fs-write-stream-atomic",
"fstream",
"fstream-npm",
"glob",
"graceful-fs",
"has-unicode",
"hosted-git-info",
"iferr",
"inflight",
"inherits",
"ini",
"init-package-json",
"lockfile",
"lodash.clonedeep",
"lodash.union",
"lodash.uniq",
"lodash.without",
"mkdirp",
"node-gyp",
"nopt",
"normalize-git-url",
"normalize-package-data",
"npm-cache-filename",
"npm-install-checks",
"npm-package-arg",
"npm-registry-client",
"npm-user-validate",
"npmlog",
"once",
"opener",
"osenv",
"path-is-inside",
"read",
"read-installed",
"read-package-json",
"read-package-tree",
"realize-package-specifier",
"retry",
"rimraf",
"semver",
"sha",
"slide",
"sorted-object",
"tar",
"text-table",
"uid-number",
"umask",
"unique-filename",
"unpipe",
"validate-npm-package-name",
"which",
"wrappy",
"write-file-atomic"
],
"devDependencies": {
"deep-equal": "~1.0.0",
"eslint": "~0.24.1",
"estraverse": "~4.1.0",
"marked": "~0.3.3",
"marked-man": "~0.1.5",
"nock": "~2.9.1",
"npm-registry-couchapp": "~2.6.11",
"npm-registry-mock": "~1.0.0",
"require-inject": "~1.2.0",
"sprintf-js": "~1.0.2",
"standard": "~4.5.4",
"tap": "~1.3.1"
},
"scripts": {
"dumpconf": "env | grep npm | sort | uniq",
"prepublish": "bash scripts/installable.sh && node bin/npm-cli.js prune --prefix=. --no-global && rimraf test/*/*/node_modules && make -j4 doc",
"preversion": "bash scripts/update-authors.sh && git add AUTHORS && git commit -m \"update AUTHORS\" || true",
"tap": "tap --timeout 240 test/tap/*.js",
"test": "standard && npm run tap",
"test-all": "standard && npm run test-legacy && npm run tap",
"test-legacy": "node ./test/run.js"
},
"license": "Artistic-2.0"
}
Jump to Line
Something went wrong with that request. Please try again.