Skip to content
This repository
tag: v1.0.1rc7
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 35 lines (34 sloc) 0.731 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
.\" Generated with Ronnjs/v0.1
.\" http://github.com/kapouer/ronnjs/
.
.TH "NPM\-DEPRECATE" "1" "March 2011" "" ""
.
.SH "NAME"
\fBnpm-deprecate\fR \-\- Deprecate a version of a package
.
.SH "SYNOPSIS"
.
.nf
npm deprecate <name>[@<version>] <message>
.
.fi
.
.SH "DESCRIPTION"
This command will update the npm registry entry for a package, providing
a deprecation warning to all who attempt to install it\.
.
.P
It works on version ranges as well as specific versions, so you can do
something like this:
.
.IP "" 4
.
.nf
npm deprecate my\-thing@"< 0\.2\.3" "critical bug fixed in v0\.2\.3"
.
.fi
.
.IP "" 0
.
.P
Note that you must be the package owner to deprecate something\. See the \fBowner\fR and \fBadduser\fR help topics\.
Something went wrong with that request. Please try again.