Permalink
Browse files

Prevent accidental updating.

Because npm 1.0 is not completely backwards-compatible with
npm 0.x, users of the old version will likely want to remove or
migrate installed packages before updating.
  • Loading branch information...
1 parent 9407d03 commit c7d2b7526854638a26a4157c20b23bb2c043c088 @isaacs isaacs committed Mar 11, 2011
Showing with 1 addition and 1 deletion.
  1. +1 −1 package.json
View
@@ -52,7 +52,7 @@
, "dependencies" : { "semver" : "1" }
, "bundleDependencies" : [ "semver" ]
, "devDependencies" : { "ronn" : "" }
-, "engines" : { "node" : "0.4 || 0.5" }
+, "engines" : { "node" : "0.4 || 0.5", "npm" : "1" }
, "scripts" : { "test" : "make test"
, "postinstall" : "sh ./scripts/install-message.sh"
}

0 comments on commit c7d2b75

Please sign in to comment.