Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Docs for npm update

  • Loading branch information...
commit e4f17a97c555d0ce7e4329774e20f16c87f977af 1 parent 3b35584
isaacs isaacs authored
Showing with 50 additions and 0 deletions.
  1. +23 −0 doc/update.md
  2. +27 −0 man/update.1
23 doc/update.md
View
@@ -0,0 +1,23 @@
+npm-update(1) -- Update a package
+=================================
+
+## SYNOPSIS
+
+ npm update [<pkg> [<pkg> ...]]
+
+## DESCRIPTION
+
+This command will update all the packages listed to the latest version
+(specified by the `tag` config), as well as updating any dependent
+packages to use the new version, if possible.
+
+Additionally, it will activate the new version, and delete any old versions, if
+safe to do so
+
+If the `update-dependents` configuration parameter is set to `"true"`, then
+packages will always be updated when they are installed, if they are the newest
+version.
+
+If the `update-dependents` configuration parameter is set to `"always"`, then
+packages will be updated when they are installed, even if to do so would be a
+downgrade.
27 man/update.1
View
@@ -0,0 +1,27 @@
+.\" generated with Ronn/v0.7.3
+.\" http://github.com/rtomayko/ronn/tree/0.7.3
+.
+.TH "NPM\-UPDATE" "1" "August 2010" "" ""
+.
+.SH "NAME"
+\fBnpm\-update\fR \- Update a package
+.
+.SH "SYNOPSIS"
+.
+.nf
+
+npm update [<pkg> [<pkg> \.\.\.]]
+.
+.fi
+.
+.SH "DESCRIPTION"
+This command will update all the packages listed to the latest version (specified by the \fBtag\fR config), as well as updating any dependent packages to use the new version, if possible\.
+.
+.P
+Additionally, it will activate the new version, and delete any old versions, if safe to do so
+.
+.P
+If the \fBupdate\-dependents\fR configuration parameter is set to \fB"true"\fR, then packages will always be updated when they are installed, if they are the newest version\.
+.
+.P
+If the \fBupdate\-dependents\fR configuration parameter is set to \fB"always"\fR, then packages will be updated when they are installed, even if to do so would be a downgrade\.
Please sign in to comment.
Something went wrong with that request. Please try again.