Skip to content
This repository

Jul 17, 2012

  1. Isaac Z. Schlueter

    v1.1.43

    authored July 17, 2012
  2. Isaac Z. Schlueter

    v1.1.42

    authored July 16, 2012

Jul 13, 2012

  1. Isaac Z. Schlueter

    v1.1.41

    authored July 13, 2012

Jul 12, 2012

  1. Isaac Z. Schlueter

    v1.1.40

    authored July 12, 2012
  2. Isaac Z. Schlueter

    v1.1.39

    authored July 11, 2012
  3. Isaac Z. Schlueter

    Fix npm running on 0.9.x versions

    authored July 11, 2012

Jul 11, 2012

  1. Isaac Z. Schlueter

    v1.1.38

    authored July 11, 2012

Jul 10, 2012

  1. Isaac Z. Schlueter

    v1.1.37

    authored July 10, 2012
  2. Isaac Z. Schlueter

    read-package-json@0.1.1

    authored July 10, 2012
  3. Isaac Z. Schlueter

    Add couch-login dep, and update npm-registry-client

    authored July 09, 2012

Jul 07, 2012

  1. Isaac Z. Schlueter

    v1.1.36

    authored July 07, 2012

Jun 29, 2012

  1. Isaac Z. Schlueter

    v1.1.35

    authored June 29, 2012
  2. Isaac Z. Schlueter

    v1.1.34

    authored June 29, 2012
  3. Isaac Z. Schlueter

    v1.1.33

    authored June 28, 2012

Jun 28, 2012

  1. Isaac Z. Schlueter

    Add retry dependency

    authored June 28, 2012

Jun 27, 2012

  1. Isaac Z. Schlueter

    s/lock-file/lockfile/

    authored June 27, 2012
  2. Isaac Z. Schlueter

    Add lock-file dependency

    authored June 26, 2012

Jun 22, 2012

  1. Isaac Z. Schlueter

    v1.1.32

    authored June 22, 2012

Jun 21, 2012

  1. Isaac Z. Schlueter

    v1.1.31

    authored June 21, 2012

Jun 19, 2012

  1. Isaac Z. Schlueter

    v1.1.30

    authored June 19, 2012
  2. James Halliday

    Fix #2538 Properly ignore false ancestors

    When running `npm install` in a package, if one of the deps depends on
    the root package, it might not be require()-able (if the folder name
    doens't match, and/or if it's not in a node_modules folder).
    
    This makes that work.
    
    Originally by @SubStack, edited slightly by @isaacs.
    
    * failing test for pkg.name that can't be required
    * fix the false_name test by altering data.name when it's not in a
      requirable location
    * set data.name to null for unrequirable packages, less hackishly
    authored June 18, 2012 isaacs committed June 19, 2012
  3. Isaac Z. Schlueter

    v1.1.29

    authored June 18, 2012

Jun 18, 2012

  1. Isaac Z. Schlueter

    v1.1.28

    authored June 18, 2012
  2. Isaac Z. Schlueter

    x

    authored June 17, 2012
  3. Isaac Z. Schlueter

    Add osenv module

    authored June 17, 2012

Jun 17, 2012

  1. Isaac Z. Schlueter

    v1.1.27

    authored June 17, 2012
  2. Isaac Z. Schlueter

    sort bundleDependencies list the same as deps

    authored June 17, 2012
  3. Isaac Z. Schlueter

    Install init-package-json module

    authored June 16, 2012

Jun 15, 2012

  1. Isaac Z. Schlueter

    v1.1.26

    authored June 15, 2012
  2. Isaac Z. Schlueter

    Update node-gyp to 0.5

    authored June 15, 2012

Jun 12, 2012

  1. Isaac Z. Schlueter

    Add glob as a dependency

    authored June 11, 2012

Jun 11, 2012

  1. Isaac Z. Schlueter

    Use read-installed dependency

    authored June 11, 2012
  2. Isaac Z. Schlueter

    Add read-package-json dep

    authored June 11, 2012
  3. Isaac Z. Schlueter

    Update lru-cache

    authored June 11, 2012
  4. Isaac Z. Schlueter

    v1.1.25

    authored June 11, 2012
Something went wrong with that request. Please try again.