Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

npm batman does not install on nodes >= 0.6.2 #1747

Closed
jefferyvincent opened this Issue · 4 comments

2 participants

@jefferyvincent

I am seeing the following issue installing batman:

zadgtdhjw:~ jefferyvincent$ sudo npm install -g batman
npm ERR! error installing batman@0.7.5 Error: No compatible version found: connect@'>=1.6.1- <1.7.0-'
npm ERR! error installing batman@0.7.5 Valid install targets:
npm ERR! error installing batman@0.7.5 ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.1.0","0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","0.2.6","0.2.7","0.3.0","0.4.0","0.5.0","0.5.1","0.5.2","0.5.3","0.5.4","0.5.5","0.5.6","0.5.7","0.5.8","0.5.9","0.5.10","1.0.0","1.0.1","1.7.2","1.7.3","1.8.0"]
npm ERR! error installing batman@0.7.5 at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! error installing batman@0.7.5 at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! error installing batman@0.7.5 at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! error installing batman@0.7.5 at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)
npm ERR! Error: No compatible version found: connect@'>=1.6.1- <1.7.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.1.0","0.2.0","0.2.1","0.2.2","0.2.3","0.2.4","0.2.5","0.2.6","0.2.7","0.3.0","0.4.0","0.5.0","0.5.1","0.5.2","0.5.3","0.5.4","0.5.5","0.5.6","0.5.7","0.5.8","0.5.9","0.5.10","1.0.0","1.0.1","1.7.2","1.7.3","1.8.0"]
npm ERR! at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)
npm ERR! Report this *entire* log at:
npm ERR!
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com
npm ERR!
npm ERR! System Darwin 11.2.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "batman"
npm ERR! cwd /Users/jefferyvincent
npm ERR! node -v v0.6.2
npm ERR! npm -v 1.0.106
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /Users/jefferyvincent/npm-debug.log
npm not ok


Not certain as to what I need to do to resolve this.

@jefferyvincent

so I stumbled across this :

batmanjs/batman#224

There's a number of broken dependencies:

connect
node-glob
node-qunit

Out of these, connect is only needed for installs, so we could maybe bump that, but we can't run the tests on the new nodes because of the other breakages. node-qunit also has a prelease version which uses the new fork APIs, which is awesome for the new nodes, and just doesn't work on old ones. Internally we have to decide when to move up and drop support for 0.4 which is hopefully soon but being blocked by 'node-glob' and 'node-qunit'.

@jefferyvincent

I think this has to do with System Darwin 11.2.0 (Mac OS X 10.7.2) as I installed it no problem in 10.5.

@jefferyvincent

Actually this issue has to do with batman.js being incompatible with node 6

Steps to resolve this issue for OS X 10.7.2 and install batman.js:

1 ) Uninstall node 6.0.2 and Install node v0.4.1 ( http://stackoverflow.com/questions/5650169/uninstall-node-js-using-linux-command-line using a binary)

2 ) Execute the X-code installer ( "Install Xcode.app") from the applications folder if you have not done so already.

Run the following commands in the terminal:

a)$: curl http://npmjs.org/install.sh | sudo sh

b)$: sudo npm install -g batman

c)$: cd ~/code

d)$: batman new my_app

e)$: cd my_app
f)$: batman server


open http://localhost:1047

Now you should be ready to Kick some Apps!

@fibric

I think the batman guys should upgrade to more up-to-date dependencies.
I could install batman on OS X Lion 10.7.3 by using
npm install batman --force

it sadly install of cause old connect version and old coffee-script version.
I downloaded the latest .gz archive from http://search.npmjs.org/#/batman
Then I edited the package.json file and fired the installer from inside of the extracted archive (with new package.json file)
npm install
and it installed and exit with "ok".
Batman just runs fine as far as I can say.

Batman 0.8.0 has a new entry in package.json file it is the engine part.
engines": { "node": "0.4.x" }
That engine key is present since 0.8.0 and was not part of the package.json file before. So batman ~0.7.5< installed somehow without big errors on any nodejs version.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.