npm can't install url #1810

Closed
jaimeguzman opened this Issue Nov 29, 2011 · 1 comment

Comments

Projects
None yet
2 participants

npm ERR! error installing url@0.4.9 Error: No compatible version found: querystring@'>=0.0.0'
npm ERR! error installing url@0.4.9 No valid targets found.
npm ERR! error installing url@0.4.9 Perhaps not compatible with your version of node?
npm ERR! error installing url@0.4.9 at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! error installing url@0.4.9 at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! error installing url@0.4.9 at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! error installing url@0.4.9 at Object.cb as oncomplete
npm ERR! Error: No compatible version found: querystring@'>=0.0.0'
npm ERR! No valid targets found.
npm ERR! Perhaps not compatible with your version of node?
npm ERR! at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! at Object.cb as oncomplete
npm ERR! Report this entire log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com
npm ERR!
npm ERR! System Linux 2.6.38-12-generic
npm ERR! command "node" "/usr/local/bin/npm" "install" "url"
npm ERR! cwd /home/djaspix/Escritorio/fantaxico
npm ERR! node -v v0.6.3
npm ERR! npm -v 1.0.106
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/djaspix/Escritorio/folder/npm-debug.log

Owner

isaacs commented Dec 1, 2011

The problem is that the querystring package doesn't allow node 0.6. Please contact the author and ask them to update it.

@isaacs isaacs closed this Dec 1, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment