Error installing mbtiles #1878

Closed
jorgeas80 opened this Issue Dec 13, 2011 · 2 comments

Comments

Projects
None yet
2 participants

When executing: npm install mbtiles

I get this error:

npm ERR! error installing mbtiles@0.1.17 Error: No compatible version found: sqlite3@'>=2.0.17- <2.1.0-'
npm ERR! error installing mbtiles@0.1.17 Valid install targets:
npm ERR! error installing mbtiles@0.1.17 ["2.0.0","2.0.1","2.0.2","2.0.3","2.0.4","2.0.5","2.0.6","2.0.7","2.0.8","2.0.9","2.0.10","2.0.11","2.0.12","2.0.13","2.0.14","2.0.15","2.1.0","2.1.1"]
npm ERR! error installing mbtiles@0.1.17 at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! error installing mbtiles@0.1.17 at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! error installing mbtiles@0.1.17 at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! error installing mbtiles@0.1.17 at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)
npm ERR! Error: No compatible version found: sqlite3@'>=2.0.17- <2.1.0-'
npm ERR! Valid install targets:
npm ERR! ["2.0.0","2.0.1","2.0.2","2.0.3","2.0.4","2.0.5","2.0.6","2.0.7","2.0.8","2.0.9","2.0.10","2.0.11","2.0.12","2.0.13","2.0.14","2.0.15","2.1.0","2.1.1"]
npm ERR! at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:424:10)
npm ERR! at /usr/local/lib/node_modules/npm/lib/cache.js:406:17
npm ERR! at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:136:7)
npm ERR! at Object.cb [as oncomplete] (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:36:9)
npm ERR! Report this entire log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com
npm ERR!
npm ERR! System Linux 3.0.0-12-generic
npm ERR! command "node" "/usr/local/bin/npm" "install" "mbtiles"
npm ERR! cwd /home/ubuntu/Downloads/node-v0.6.5
npm ERR! node -v v0.6.5
npm ERR! npm -v 1.0.106
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/ubuntu/Downloads/node-v0.6.5/npm-debug.log
npm not ok

I have sqlite3 installed, but sqlite3 --version says: 3.7.7 2011-06-23 19:49:22 4374b7e83ea0a3fbc3691f9c0c936272862f32f2

Do I have to install an old sqlite3 version? 2.0 and 2.1 seem as too old...

Contributor

welwood08 commented Dec 14, 2011

The version of sqlite3 shown by npm is that of the node-sqlite3 package ( https://github.com/developmentseed/node-sqlite3 ), not the sqlite3 binary/library itself.

The problem here is the mbtiles specifically requests a version of node-sqlite3 greater than or equal to 2.0.17 but less than 2.1 - the only versions of node-sqlite3 that satisfy this condition are 2.0.17 and 2.0.18 and those both specifically require node < 0.5.

The versions that npm lists can be explained as follows:

  • up to 2.0.15 are from before the node-sqlite3 package declared it actually didn't work in node above 0.4 (and instead claimed to support all future node versions).
  • 2.1.0 and beyond are actually built for node 0.6.

Filing an issue over at https://github.com/mapbox/node-mbtiles/ would probably a good idea since there doesn't appear to be one yet.

Sorry, I forgot to answer this. Thanks for your solution!

jorgeas80 closed this Feb 26, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment