weird dependency conflict when using urls #2033

Closed
c4milo opened this Issue Jan 13, 2012 · 2 comments

2 participants

@c4milo

Hey @isaacs just a heads up that what I explained to you in IRC is happening as well in nodejs 0.6.7 and npm 1.1.0-beta-10

You can reproduce it by using the package.json I pasted in this gist:
https://gist.github.com/1607296

@c4milo

still running into this issue in 0.6.10. @isaacs any idea?

@c4milo

I'm still having this issue in node 0.6.14, there is something wonky with the way npm is reading installed packages when doing npm list.

I was digging a bit into npm code I found that https://github.com/isaacs/npm/blob/master/lib/utils/read-installed.js#L256-L264 is not considering dependencies as URLs. In my particular case, the value of found.version is 0.2.0 and deps[dep] is git+ssh://git@github.com:buglabs/bugswarm-domain.git#v0.2.0

Any ideas @isaacs?

@isaacs isaacs closed this in 6a8002f Apr 12, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment