Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Error installing forever@0.8.4 #2085

Closed
meritt opened this Issue Jan 24, 2012 · 2 comments

Comments

Projects
None yet
2 participants

meritt commented Jan 24, 2012

npm-debug.log

info it worked if it ends with ok
verbose cli [ 'node', '/usr/local/bin/npm', 'install', '-g', 'forever' ]
info using npm@1.1.0-2
info using node@v0.6.8
verbose config file /root/.npmrc
verbose config file /usr/local/etc/npmrc
verbose config file /usr/local/lib/node_modules/npm/npmrc
silly exec /usr/local/bin/node "/usr/local/lib/node_modules/npm/bin/npm-get-uid-gid.js" "nobody" 0
silly spawning [ '/usr/local/bin/node',
silly spawning   [ '/usr/local/lib/node_modules/npm/bin/npm-get-uid-gid.js',
silly spawning     'nobody',
silly spawning     0 ],
silly spawning   null ]
silly output from getuid/gid {"uid":65534,"gid":0}
silly output from getuid/gid 
verbose cache add [ 'forever', null ]
silly cache add: name, spec, args [ undefined, 'forever', [ 'forever', null ] ]
verbose parsed url { pathname: 'forever', path: 'forever', href: 'forever' }
verbose addNamed [ 'forever', '' ]
verbose addNamed [ null, '' ]
silly name, range, hasData [ 'forever', '', false ]
verbose raw, before any munging forever
verbose url resolving [ 'https://registry.npmjs.org/', './forever' ]
verbose url resolved https://registry.npmjs.org/forever
verbose etag "DO4Z9QJJCY6K8ZS0C0LU3NZB0"
http GET https://registry.npmjs.org/forever
http 304 https://registry.npmjs.org/forever
silly get cb [ 304,
silly get cb   { server: 'CouchDB/1.1.0 (Erlang OTP/R14B04)',
silly get cb     etag: '"DO4Z9QJJCY6K8ZS0C0LU3NZB0"',
silly get cb     date: 'Tue, 24 Jan 2012 15:09:56 GMT',
silly get cb     'content-length': '0' } ]
verbose etag forever from cache
silly name, range, hasData 2 [ 'forever', '', true ]
silly versions [ 'forever',
silly versions   [ '0.6.0',
silly versions     '0.6.1',
silly versions     '0.6.2',
silly versions     '0.6.3',
silly versions     '0.6.4',
silly versions     '0.6.5',
silly versions     '0.6.6',
silly versions     '0.6.7',
silly versions     '0.6.8',
silly versions     '0.6.9',
silly versions     '0.7.0',
silly versions     '0.7.1',
silly versions     '0.7.2',
silly versions     '0.7.3',
silly versions     '0.7.4',
silly versions     '0.7.5',
silly versions     '0.8.0',
silly versions     '0.8.1',
silly versions     '0.8.2',
silly versions     '0.8.3',
silly versions     '0.8.4' ] ]
verbose bin dist [ '0.6-ares1.7.5-DEV-evundefined-openssl1.0.0e-v83.6.6.19-linux-ia32-3.0.4-linode38',
verbose bin dist   { shasum: '3273cfc160fcef6d183508a09dd2e70184e15aba',
verbose bin dist     tarball: 'http://registry.npmjs.org/forever/-/forever-0.8.4.tgz' } ]
verbose caching /root/.npm/forever/0.8.4/package/package.json
verbose loadDefaults forever@0.8.4
silly resolved [ { name: 'forever',
silly resolved     preferGlobal: 'true',
silly resolved     description: 'A simple CLI tool for ensuring that a given node script runs continuously (i.e. forever)',
silly resolved     version: '0.8.4',
silly resolved     author: { name: 'Nodejitsu Inc', email: 'info@nodejitsu.com' },
silly resolved     contributors: 
silly resolved      [ { name: 'Charlie Robbins', email: 'charlie@nodejitsu.com' },
silly resolved        { name: 'Fedor Indutny', email: 'fedor.indutny@gmail.com' },
silly resolved        { name: 'James Halliday', email: 'mail@substack.net' },
silly resolved        { name: 'Bradley Meck', email: 'bradley@nodejitsu.com' },
silly resolved        { name: 'Dominic Tarr', email: 'dominic@nodejitsu.com' },
silly resolved        { name: 'Maciej Małecki', email: 'maciej@nodejitsu.com' } ],
silly resolved     repository: { type: 'git', url: 'git://github.com/nodejitsu/forever.git' },
silly resolved     keywords: [ 'cli', 'fault tolerant', 'sysadmin', 'tools' ],
silly resolved     dependencies: 
silly resolved      { broadway: '0.1.x',
silly resolved        cliff: '0.x.x',
silly resolved        daemon: '0.4.x',
silly resolved        flatiron: '0.1.x',
silly resolved        microtime: '0.2.x',
silly resolved        minimatch: '0.0.x',
silly resolved        nconf: '0.5.x',
silly resolved        nssocket: '0.3.x',
silly resolved        'node-fork': '0.4.x',
silly resolved        optimist: '0.2.x',
silly resolved        pkginfo: '0.x.x',
silly resolved        portfinder: '0.x.x',
silly resolved        'ps-tree': '0.0.x',
silly resolved        timespan: '2.0.x',
silly resolved        watch: '0.5.x',
silly resolved        utile: '0.0.x',
silly resolved        winston: '0.5.x' },
silly resolved     devDependencies: { eventemitter2: '0.4.x', request: '2.x.x', vows: '0.5.x' },
silly resolved     bin: { forever: './bin/forever', foreverd: './bin/foreverd' },
silly resolved     main: './lib/forever',
silly resolved     scripts: { test: 'vows test/**/*-test.js --spec -i' },
silly resolved     engines: { node: '>= 0.4.8' },
silly resolved     _id: 'forever@0.8.4',
silly resolved     optionalDependencies: {},
silly resolved     _engineSupported: true,
silly resolved     _npmVersion: '1.1.0-2',
silly resolved     _nodeVersion: 'v0.6.8',
silly resolved     _defaultsLoaded: true } ]
info into /usr/local/lib forever@0.8.4
info installOne forever@0.8.4
info unbuild /usr/local/lib/node_modules/forever
verbose from cache /root/.npm/forever/0.8.4/package/package.json
verbose mkdir (expected) error ENOENT, no such file or directory '/usr/local/lib/node_modules/___forever.npm'
verbose mkdir done: /usr/local/lib/node_modules/___forever.npm 755
verbose unpack_ uid, gid [ 65534, 0 ]
verbose unpackTarget /usr/local/lib/node_modules/forever
silly gunzTarPerm modes [ '755', '644' ]
silly afterUntar undefined
verbose gunzed /usr/local/lib/node_modules/___forever.npm
verbose rm'ed /usr/local/lib/node_modules/forever
verbose renamed [ '/usr/local/lib/node_modules/___forever.npm',
verbose renamed   '/usr/local/lib/node_modules/forever' ]
ERR! error installing forever@0.8.4
info unbuild /usr/local/lib/node_modules/forever
verbose installOne cb forever@0.8.4
ERR! Error: ENOENT, no such file or directory '/usr/local/lib/node_modules/forever/package.json'
ERR! You may report this log at:
ERR!     <http://github.com/isaacs/npm/issues>
ERR! or email it to:
ERR!     <npm-@googlegroups.com>
ERR! 
ERR! System Linux 3.0.4-linode38
ERR! command "node" "/usr/local/bin/npm" "install" "-g" "forever"
ERR! cwd /root
ERR! node -v v0.6.8
ERR! npm -v 1.1.0-2
ERR! path /usr/local/lib/node_modules/forever/package.json
ERR! code ENOENT
ERR! message ENOENT, no such file or directory '/usr/local/lib/node_modules/forever/package.json'
ERR! errno {}
verbose exit [ 1, true ]

uname -a

Linux li311-105 3.0.4-linode38 #1 SMP Thu Sep 22 14:59:08 EDT 2011 i686 i686 i386 GNU/Linux

meritt commented Jan 24, 2012

Maybe it's because optimist@0.3.1 installation failed

npm-debug.log

info it worked if it ends with ok
verbose cli [ 'node', '/usr/local/bin/npm', 'install', '-g', 'optimist' ]
info using npm@1.1.0-2
info using node@v0.6.8
verbose config file /root/.npmrc
verbose config file /usr/local/etc/npmrc
verbose config file /usr/local/lib/node_modules/npm/npmrc
silly exec /usr/local/bin/node "/usr/local/lib/node_modules/npm/bin/npm-get-uid-gid.js" "nobody" 0
silly spawning [ '/usr/local/bin/node',
silly spawning   [ '/usr/local/lib/node_modules/npm/bin/npm-get-uid-gid.js',
silly spawning     'nobody',
silly spawning     0 ],
silly spawning   null ]
silly output from getuid/gid {"uid":65534,"gid":0}
silly output from getuid/gid 
verbose cache add [ 'optimist', null ]
silly cache add: name, spec, args [ undefined, 'optimist', [ 'optimist', null ] ]
verbose parsed url { pathname: 'optimist', path: 'optimist', href: 'optimist' }
verbose addNamed [ 'optimist', '' ]
verbose addNamed [ null, '' ]
silly name, range, hasData [ 'optimist', '', false ]
verbose raw, before any munging optimist
verbose url resolving [ 'https://registry.npmjs.org/', './optimist' ]
verbose url resolved https://registry.npmjs.org/optimist
verbose etag "2TYAHMZL99I68R2ZVSXBVAQM9"
http GET https://registry.npmjs.org/optimist
http 304 https://registry.npmjs.org/optimist
silly get cb [ 304,
silly get cb   { server: 'CouchDB/1.1.0 (Erlang OTP/R14B04)',
silly get cb     etag: '"2TYAHMZL99I68R2ZVSXBVAQM9"',
silly get cb     date: 'Tue, 24 Jan 2012 15:42:26 GMT',
silly get cb     'content-length': '0' } ]
verbose etag optimist from cache
silly name, range, hasData 2 [ 'optimist', '', true ]
silly versions [ 'optimist',
silly versions   [ '0.0.1',
silly versions     '0.0.2',
silly versions     '0.0.4',
silly versions     '0.0.5',
silly versions     '0.0.6',
silly versions     '0.0.7',
silly versions     '0.1.0',
silly versions     '0.1.1',
silly versions     '0.1.2',
silly versions     '0.1.3',
silly versions     '0.1.4',
silly versions     '0.1.5',
silly versions     '0.1.6',
silly versions     '0.1.7',
silly versions     '0.1.8',
silly versions     '0.1.9',
silly versions     '0.0.3',
silly versions     '0.2.0',
silly versions     '0.2.1',
silly versions     '0.2.2',
silly versions     '0.2.3',
silly versions     '0.2.4',
silly versions     '0.2.5',
silly versions     '0.2.6',
silly versions     '0.2.7',
silly versions     '0.2.8',
silly versions     '0.3.0',
silly versions     '0.3.1' ] ]
verbose bin dist [ '0.6-ares1.7.5-DEV-evundefined-openssl1.0.0e-v83.6.6.19-linux-ia32-3.0.4-linode38',
verbose bin dist   { shasum: '6680d30560193af5a55eb64394883ed7bcb98f2e',
verbose bin dist     tarball: 'http://registry.npmjs.org/optimist/-/optimist-0.3.1.tgz' } ]
verbose caching /root/.npm/optimist/0.3.1/package/package.json
verbose loadDefaults optimist@0.3.1
silly resolved [ { name: 'optimist',
silly resolved     version: '0.3.1',
silly resolved     description: 'Light-weight option parsing with an argv hash. No optstrings attached.',
silly resolved     main: './index.js',
silly resolved     directories: { lib: '.', test: 'test', example: 'examples' },
silly resolved     dependencies: { wordwrap: '>=0.0.1 <0.1.0' },
silly resolved     devDependencies: { hashish: '0.0.x', expresso: '0.7.x' },
silly resolved     scripts: { test: 'expresso' },
silly resolved     repository: 
silly resolved      { type: 'git',
silly resolved        url: 'git://github.com/substack/node-optimist.git' },
silly resolved     keywords: 
silly resolved      [ 'argument',
silly resolved        'args',
silly resolved        'option',
silly resolved        'parser',
silly resolved        'parsing',
silly resolved        'cli',
silly resolved        'command' ],
silly resolved     author: 
silly resolved      { name: 'James Halliday',
silly resolved        email: 'mail@substack.net',
silly resolved        url: 'http://substack.net' },
silly resolved     license: 'MIT/X11',
silly resolved     engine: { node: '>=0.4' },
silly resolved     _id: 'optimist@0.3.1',
silly resolved     optionalDependencies: {},
silly resolved     engines: { node: '*' },
silly resolved     _engineSupported: true,
silly resolved     _npmVersion: '1.1.0-2',
silly resolved     _nodeVersion: 'v0.6.8',
silly resolved     _defaultsLoaded: true } ]
info into /usr/local/lib optimist@0.3.1
info installOne optimist@0.3.1
info unbuild /usr/local/lib/node_modules/optimist
verbose from cache /root/.npm/optimist/0.3.1/package/package.json
verbose mkdir (expected) error ENOENT, no such file or directory '/usr/local/lib/node_modules/___optimist.npm'
verbose mkdir done: /usr/local/lib/node_modules/___optimist.npm 755
verbose unpack_ uid, gid [ 65534, 0 ]
verbose unpackTarget /usr/local/lib/node_modules/optimist
silly gunzTarPerm modes [ '755', '644' ]
silly afterUntar undefined
verbose gunzed /usr/local/lib/node_modules/___optimist.npm
verbose rm'ed /usr/local/lib/node_modules/optimist
verbose renamed [ '/usr/local/lib/node_modules/___optimist.npm',
verbose renamed   '/usr/local/lib/node_modules/optimist' ]
ERR! error installing optimist@0.3.1
info unbuild /usr/local/lib/node_modules/optimist
verbose installOne cb optimist@0.3.1
ERR! Error: ENOENT, no such file or directory '/usr/local/lib/node_modules/optimist/package.json'
ERR! You may report this log at:
ERR!     <http://github.com/isaacs/npm/issues>
ERR! or email it to:
ERR!     <npm-@googlegroups.com>
ERR! 
ERR! System Linux 3.0.4-linode38
ERR! command "node" "/usr/local/bin/npm" "install" "-g" "optimist"
ERR! cwd /root
ERR! node -v v0.6.8
ERR! npm -v 1.1.0-2
ERR! path /usr/local/lib/node_modules/optimist/package.json
ERR! code ENOENT
ERR! message ENOENT, no such file or directory '/usr/local/lib/node_modules/optimist/package.json'
ERR! errno {}
verbose exit [ 1, true ]
Contributor

luk- commented Mar 9, 2013

Hit this up again with more up to date stuff

@luk- luk- closed this Mar 9, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment