bundleDependencies isn't being published properly #2147

Closed
TooTallNate opened this Issue Feb 11, 2012 · 5 comments

Projects

None yet

7 participants

@TooTallNate

I'm trying to add all the dependencies in node-gyp as "bundleDependencies", but when I publish the module and 2nd level dependencies don't get installed:

├─┬ node-gyp@0.0.5 
│ ├── ansi@0.0.3 
│ ├─┬ glob@3.0.1 
│ │ ├── UNMET DEPENDENCY fast-list 1
│ │ ├── UNMET DEPENDENCY graceful-fs ~1.1.2
│ │ └── UNMET DEPENDENCY inherits 1
│ ├─┬ minimatch@0.1.5 
│ │ └── UNMET DEPENDENCY lru-cache ~1.0.5
│ ├── mkdirp@0.3.0 
│ ├─┬ nopt@1.0.10 
│ │ └── UNMET DEPENDENCY abbrev 1
│ ├── request@2.9.100 
│ ├── rimraf@2.0.1 
│ ├─┬ tar@0.1.12 
│ │ ├── UNMET DEPENDENCY block-stream *
│ │ ├── UNMET DEPENDENCY fstream ~0.1.8
│ │ └── UNMET DEPENDENCY inherits 1.x
│ └── which@1.0.3 

Not quite sure what the problem is but I'm gonna back out the "bundleDependencies" for now.

@chakrit
chakrit commented Sep 3, 2012

Related: request/request#313

This breaks npm shrinkwrap and also npm install as well. As now packages with bundle depedencies are not installing correctly.

@Almad
Almad commented Sep 4, 2012

+1

@andreineculau

bump

@isaacs
Member
isaacs commented May 2, 2013

@andreineculau Watch yourself. These issues have hard corners, you don't want to be bumping into them accidentally.

@iarna iarna added the bug label Oct 17, 2014
@shesek shesek referenced this issue in substack/bundle-collapser Feb 17, 2015
Closed

Upgrade falafel to 1.0.0? #11

@zkat
Member
zkat commented Dec 3, 2016

This seems to have been fixed. We've done a lot of installer work since this bug was posted, and npm pack-ing node-gyp after adding all its deps to bundleDependencies seems to be 🆗 🙆

@zkat zkat closed this Dec 3, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment