Error installing 'ws' via npm on Ubuntu 11.10 #2364

hisankaran opened this Issue Apr 12, 2012 · 2 comments


None yet

3 participants


sankaran@ubuntu:~$ npm install ws
node-waf configure build
Checking for program g++ or c++ : /usr/bin/g++
Checking for program cpp : /usr/bin/cpp
Checking for program ar : /usr/bin/ar
Checking for program ranlib : /usr/bin/ranlib
Checking for g++ : ok

Checking for node path : ok /home/sankaran/.node_libraries
Checking for node prefix : ok /usr
'configure' finished successfully (0.032s)
Waf: Entering directory /home/sankaran/.node_libraries/.npm/ws/0.4.12/package/build'
[1/4] cxx: src/ -> build/default/src/validation_1.o
[2/4] cxx: src/ -> build/default/src/bufferutil_2.o
[3/4] cxx_link: build/default/src/validation_1.o -> build/default/validation.node
[4/4] cxx_link: build/default/src/bufferutil_2.o -> build/default/bufferutil.node
Waf: Leaving directory
'build' finished successfully (0.630s)
npm ERR! install failed Error: Required package: options(latest) not found. (Found: ["0.0.3"])
npm ERR! install failed (required by: ws@0.4.12)
npm ERR! install failed at /usr/share/npm/lib/build.js:192:19
npm ERR! install failed at cb (/usr/share/npm/lib/utils/graceful-fs.js:32:9)
npm ERR! Error: Required package: options(latest) not found. (Found: ["0.0.3"])
npm ERR! (required by: ws@0.4.12)
npm ERR! at /usr/share/npm/lib/build.js:192:19
npm ERR! at cb (/usr/share/npm/lib/utils/graceful-fs.js:32:9)
npm ERR! Report this entire log at
npm ERR! or email it to
npm ERR! Just tweeting a tiny part of the error will not be helpful.
npm not ok


Looks like a waf issue, which is deprecated now. Try using a later version of node that uses gyp to build native extensions.

@luk- luk- closed this Mar 9, 2013
npm member

It's also a dupe of #2815.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment