npm search: Building index never completes (SSL error?) #2467

Closed
DennisKehrig opened this Issue May 22, 2012 · 5 comments

Comments

Projects
None yet
5 participants
@DennisKehrig

$ npm search
npm WARN Building the local index for the first time, please be patient
npm http GET https://registry.npmjs.org/-/all

Hours later: nothing changed. I am not that patient ;)

Opening https://registry.npmjs.org/-/all in Chrome results in an security error: Invalid Server Certificate
"In this case, the server certificate or an intermediate CA certificate presented to your browser is invalid. This may mean that the certificate is malformed, contains invalid fields, or is not supported."

The error message in Firefox seems more helpful:
registry.npmjs.org uses an invalid security certificate.
The certificate is not trusted because no issuer chain was provided.
(Error code: sec_error_unknown_issuer)

@isaacs

This comment has been minimized.

Show comment Hide comment
@isaacs

isaacs Jun 4, 2012

Member

The ssl error has nothing to do with this. The chrome error (which you can't even bypass!) is a bug in chrome (which we've worked around by providing a 2048-bit key). Firefox's complaint is that you don't have the CA in your computer's keychain. (But it is in npm's internal keychain, and is the only CA it trusts.)

Can you try again? It should take no more than a few minutes the first time.

Member

isaacs commented Jun 4, 2012

The ssl error has nothing to do with this. The chrome error (which you can't even bypass!) is a bug in chrome (which we've worked around by providing a 2048-bit key). Firefox's complaint is that you don't have the CA in your computer's keychain. (But it is in npm's internal keychain, and is the only CA it trusts.)

Can you try again? It should take no more than a few minutes the first time.

@isaacs isaacs closed this Jun 4, 2012

@DennisKehrig

This comment has been minimized.

Show comment Hide comment
@DennisKehrig

DennisKehrig Jun 5, 2012

It works now! Took under 4 minutes to complete. Thank you :)

It works now! Took under 4 minutes to complete. Thank you :)

@shanimal

This comment has been minimized.

Show comment Hide comment
@shanimal

shanimal Nov 2, 2012

I get this everytime I do search. Any recommendations?

/Users/Apple/Sites/_www>ender search jquery 0

Welcome to ENDER - The no-library library

searching NPM registry...
npm WARN Building the local index for the first time, please be patient
npm http GET https://registry.npmjs.org/-/all
npm http 200 https://registry.npmjs.org/-/all

sorry, we couldn't find anything. :(
something went wrong searching npm!

shanimal commented Nov 2, 2012

I get this everytime I do search. Any recommendations?

/Users/Apple/Sites/_www>ender search jquery 0

Welcome to ENDER - The no-library library

searching NPM registry...
npm WARN Building the local index for the first time, please be patient
npm http GET https://registry.npmjs.org/-/all
npm http 200 https://registry.npmjs.org/-/all

sorry, we couldn't find anything. :(
something went wrong searching npm!

@shanimal

This comment has been minimized.

Show comment Hide comment
@shanimal

shanimal Nov 2, 2012

fwiw: the '0' at the end of "ender search jquery 0" is the return value from the command "ender search jquery"

shanimal commented Nov 2, 2012

fwiw: the '0' at the end of "ender search jquery 0" is the return value from the command "ender search jquery"

@FroPT

This comment has been minimized.

Show comment Hide comment
@FroPT

FroPT Sep 8, 2014

Please help,
I'm a newbie to Node.js and i'm not an engineer.
I'm having the same problem DennisKehrig did (I think).
But i didn't get the answer to solve it.

I just installed Node.js [v0.10.31], then i did :
me$ sudo npm search
npm WARN Building the local index for the first time, please be patient

But nothing happens...

I've cancelled the operation after more than an hour...
then i've done:
me$ sudo npm cache clean
me$ sudo npm search (again but i got the same result)

Could some one help me?
I'm using a mac os x 10.9.4
Thank you

FroPT commented Sep 8, 2014

Please help,
I'm a newbie to Node.js and i'm not an engineer.
I'm having the same problem DennisKehrig did (I think).
But i didn't get the answer to solve it.

I just installed Node.js [v0.10.31], then i did :
me$ sudo npm search
npm WARN Building the local index for the first time, please be patient

But nothing happens...

I've cancelled the operation after more than an hour...
then i've done:
me$ sudo npm cache clean
me$ sudo npm search (again but i got the same result)

Could some one help me?
I'm using a mac os x 10.9.4
Thank you

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment