Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Cannot install few apps thanks to "solution configuration" #2671

Closed
neoswf opened this Issue · 2 comments

2 participants

@neoswf

My NPM does problems while installing some apps. Other it installs without any issues.

I am trying installing node.io, and it fails and gives me these errors:
(i'm using win7, with python installed)

C:\Users\computername\AppData\Roaming\npm\node_modules\node.io\node_modules\jsdom\node_modules\contextify\build\binding.sln.metaproj : error MSB4126: The specified solution configuration "Release|Win64" is invalid. Please specify a valid solution configuration using the Configuration and Platform properties (e.g. MSBuild.exe Solution.sln /p:Configuration=Debug /p:Platform="Any CPU") or leave those properties blank to use the default solution configuration. [C:\Users\computername\AppData\Roaming\npm\node_modules\node.io\node_modules\jsdom\node_modules\contextify\build\binding.sln]

Than I started trying to stabelize all, and installed some of the apps that where missing in the list:
npm http GET https://registry.npmjs.org/node.io
npm http 304 https://registry.npmjs.org/node.io
npm http GET https://registry.npmjs.org/jquery
npm http GET https://registry.npmjs.org/htmlparser
npm http GET https://registry.npmjs.org/request/2.9.202
npm http GET https://registry.npmjs.org/jsdom
npm http GET https://registry.npmjs.org/coffee-script
npm http 304 https://registry.npmjs.org/jsdom
npm http 304 https://registry.npmjs.org/coffee-script
npm http 304 https://registry.npmjs.org/htmlparser
npm http 304 https://registry.npmjs.org/request/2.9.202
npm http 304 https://registry.npmjs.org/jquery
npm http GET https://registry.npmjs.org/xmlhttprequest
npm http GET https://registry.npmjs.org/navigator
npm http GET https://registry.npmjs.org/location/0.0.1
npm http GET https://registry.npmjs.org/contextify
npm http GET https://registry.npmjs.org/cssom
npm http 304 https://registry.npmjs.org/xmlhttprequest
npm http 304 https://registry.npmjs.org/navigator
npm http 304 https://registry.npmjs.org/cssom
npm http 304 https://registry.npmjs.org/location/0.0.1
npm http 304 https://registry.npmjs.org/contextify
npm http GET https://registry.npmjs.org/bindings
npm http 304 https://registry.npmjs.org/bindings

So I tryed installed JSDom, bindings, coffee, contextify, just to see that lack of them isn't the thing that gave me the problems, contextify throwed me the following errors:
npm ERR! contextify@0.1.3 install: node-gyp rebuild
npm ERR! cmd "/c" "node-gyp rebuild" failed with 1
npm ERR!
npm ERR! Failed at the contextify@0.1.3 install script.
npm ERR! This is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild
npm ERR! You can get their info via:
npm ERR! npm owner ls contextify
npm ERR! There is likely additional logging output above.
npm ERR!
npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\Program Files (x86)\nodejs\\node.exe" "C:\Program File
s (x86)\nodejs\node_modules\npm\bin\npm-cli.js" "i" "-g" "contextify"
npm ERR! cwd C:\Windows\system32
npm ERR! node -v v0.6.14
npm ERR! npm -v 1.1.12
npm ERR! code ELIFECYCLE
npm ERR! message contextify@0.1.3 install: node-gyp rebuild
npm ERR! message cmd "/c" "node-gyp rebuild" failed with 1
npm ERR! errno {}
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! C:\Windows\system32\npm-debug.log
npm not ok

Problem is that I have tried installing few apps and I get errors on more than one.
Is there any way these problems are familiar to somebody that might give me a hand?

Thank you.

@mfncooper
Collaborator

The error messages for the contextify problem include the following:

npm ERR! Failed at the contextify@0.1.3 install script.
npm ERR! This is most likely a problem with the contextify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-gyp rebuild

You should follow up with the contextify author, as suggested. Also, you should update to a newer version of npm, since the one you have is quite old. If you can update to Node v0.8.x, you should do that too.

@mfncooper mfncooper closed this
@neoswf

Thank you @mfncooper. I'll take a look at my node version.
I noticed contextify msg saying that it isn't npm problem, but too many apps gave me these msgs, that I was wondering if it's all the apps problem, or something else... There for I came here hoping here I'll get help.

Thank you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.