Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

404 Not Found #2693

Closed
reggi opened this Issue · 13 comments

10 participants

@reggi
1100 error Error: 404 Not Found
1100 error     at null.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/fetch.js:47:16)
1100 error     at EventEmitter.emit (events.js:115:20)
1100 error     at WriteStream.flush (fs.js:1503:12)
1100 error     at fs.close (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:94:5)
1100 error     at Object.oncomplete (fs.js:297:15)
1100 error  [Error: 404 Not Found]
1101 error You may report this log at:
1101 error     <http://github.com/isaacs/npm/issues>
1101 error or email it to:
1101 error     <npm-@googlegroups.com>
1102 error System Darwin 11.4.0
1103 error command "node" "/usr/local/bin/npm" "install"
1104 error cwd /Users/thomas/Desktop/com
1105 error node -v v0.8.2
1106 error npm -v 1.1.36
1107 error message 404 Not Found
@wachunga

Getting similar. I'm at the latest (1.1.46).

@Urthen

Getting this for anything I try and install...

npm http GET https://registry.npmjs.org/express/3.0.0rc2
npm http 304 https://registry.npmjs.org/express/3.0.0rc2
npm http GET https://registry.npmjs.org/-/express-3.0.0rc2.tgz
npm http 404 https://registry.npmjs.org/-/express-3.0.0rc2.tgz

npm ERR! Error: shasum check failed for /var/folders/px/dzl45xq142nccclbbdmtc3fmvnqych/T/npm-    1344756101737/1344756101737-0.8211007772479206/tmp.tgz
npm ERR! Expected: ffa79ccee41abc97f2c57576cc433339200fcd33
npm ERR! Actual:   3bb7b8a676e95a33a0f28f081cf860176b8f67c7
npm ERR!     at /usr/local/lib/node_modules/npm/lib/utils/sha.js:25:20
npm ERR!     at [object Object].<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/sha.js:49:5)
npm ERR!     at [object Object].emit (events.js:64:17)
npm ERR!     at afterRead (fs.js:1125:12)
npm ERR!     at Object.wrapper [as oncomplete] (fs.js:262:17)
npm ERR! You may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>
npm ERR! 
npm ERR! System Darwin 11.3.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "express"
npm ERR! cwd /******
npm ERR! node -v v0.6.15
npm ERR! npm -v 1.1.16
npm ERR! message shasum check failed for /var/folders/px/dzl45xq142nccclbbdmtc3fmvnqych/T/npm1344756101737/1344756101737-0.8211007772479206/tmp.tgz
npm ERR! message Expected: ffa79ccee41abc97f2c57576cc433339200fcd33
npm ERR! message Actual:   3bb7b8a676e95a33a0f28f081cf860176b8f67c7
@Urthen

Additionally, this doesn't seem to be a local issue - I can't push to Heroku either.

@reggi

One line above is a fetch for express

npm ERR! fetch failed http://registry.npmjs.org/-/express-3.0.0rc2.tgz

@reggi

@Urthen is the npm network down?

@Urthen

@reggi That would be my uneducated guess... no matter what I try and install, it fails with the same fetch failed error.

@go4roc

me too

@naxhh

Seems servers are down :\

@webjames

is there an NPM server status page? If there is i can't find it.

@Pirhoo

Hi guys, see #2694

@eladmoshe

Weirdly, npm still works for version 1.1.19

@roldan

still works on 1.1.19?

@eladmoshe

@roldan yes, still works

@isaacs isaacs closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.