derby shasum mismatch #2708

Closed
keithhamilton opened this Issue Aug 12, 2012 · 2 comments

2 participants

@keithhamilton

Trying to install derby via npm, and keep getting an error that the shasums don't match:

http GET https://registry.npmjs.org/-/derby-0.3.12.tgz
silly updated sha bytes 52
info shasum 3bb7b8a676e95a33a0f28f081cf860176b8f67c7
info shasum /tmp/npm-1344783781212/1344783781212-0.9077240105252713/tmp.tgz
ERR! Error: shasum check failed for /tmp/npm-1344783781212/1344783781212-0.9077240105252713/tmp.tgz
ERR! Expected: 317cd3cff9bfba5d0e89fa30337778ea0abf7ba0
ERR! Actual: 3bb7b8a676e95a33a0f28f081cf860176b8f67c7
ERR! at /usr/lib/nodejs/npm/lib/utils/sha.js:25:20
ERR! at [object Object]. (/usr/lib/nodejs/npm/lib/utils/sha.js:49:5)
ERR! at [object Object].emit (events.js:64:17)
ERR! at afterRead (fs.js:1130:12)
ERR! at Object.wrapper as oncomplete
ERR! You may report this log at:
ERR! http://github.com/isaacs/npm/issues
ERR! or email it to:
ERR! npm-@googlegroups.com
ERR!
ERR! System Linux 3.5.1-1.fc17.x86_64
ERR! command "nodejs" "/usr/bin/npm" "install" "derby"
ERR! cwd /home/keith/Downloads
ERR! node -v v0.6.18
ERR! npm -v 1.1.19
ERR! message shasum check failed for /tmp/npm-1344783781212/1344783781212-0.9077240105252713/tmp.tgz
ERR! message Expected: 317cd3cff9bfba5d0e89fa30337778ea0abf7ba0
ERR! message Actual: 3bb7b8a676e95a33a0f28f081cf860176b8f67c7

@isaacs
npm member

npm cache clean, and try again.

Also, you should upgrade to npm 1.1.50.

@isaacs isaacs closed this Aug 19, 2012
@keithhamilton
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment