Error Installing jitsu #2829

Closed
shawnthetaylor opened this Issue Sep 25, 2012 · 1 comment

Comments

Projects
None yet
2 participants
@shawnthetaylor

Not quite sure where this problem stems from...but here is the error message I'm getting. Sorry, I'm very new to using all these things and really have no idea what went wrong. Any help is greatly appreciated. Thank you!

npm ERR! error rolling back jitsu@0.9.8 Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/jitsu/node_modules/require-analyzer/node_modules/optimist/examples'

npm ERR! Error: No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! Valid install targets:
npm ERR! ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm ERR! at installTargetsError (/usr/local/lib/node_modules/npm/lib/cache.js:486:10)
npm ERR! at next_ (/usr/local/lib/node_modules/npm/lib/cache.js:436:17)
npm ERR! at next (/usr/local/lib/node_modules/npm/lib/cache.js:413:44)
npm ERR! at /usr/local/lib/node_modules/npm/lib/cache.js:406:5
npm ERR! at saved (/usr/local/lib/node_modules/npm/lib/utils/npm-registry-client/get.js:150:7)
npm ERR! at Object.oncomplete (/usr/local/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:230:7)
npm ERR! You may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com
npm ERR!
npm ERR! System Linux 3.0.0-26-generic
npm ERR! command "node" "/usr/local/bin/npm" "install" "jitsu" "-g"
npm ERR! cwd /home/shawn
npm ERR! node -v v0.6.14
npm ERR! npm -v 1.1.12
npm ERR! message No compatible version found: read@'>=1.0.0- <1.1.0-'
npm ERR! message Valid install targets:
npm ERR! message ["0.0.1","0.0.2","0.0.3","0.1.0","0.1.1"]
npm http 304 https://registry.npmjs.org/utile/0.1.2
npm http 304 https://registry.npmjs.org/winston/0.6.2
npm http 304 https://registry.npmjs.org/nconf/0.6.4
npm http GET https://registry.npmjs.org/seq

npm ERR! Error: ENOENT, open '/usr/local/lib/node_modules/jitsu/node_modules/fstream-npm/node_modules/fstream-ignore/node_modules/minimatch/minimatch.js'
npm ERR! You may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com
npm ERR!
npm ERR! System Linux 3.0.0-26-generic
npm ERR! command "node" "/usr/local/bin/npm" "install" "jitsu" "-g"
npm ERR! cwd /home/shawn
npm ERR! node -v v0.6.14
npm ERR! npm -v 1.1.12
npm ERR! path /usr/local/lib/node_modules/jitsu/node_modules/fstream-npm/node_modules/fstream-ignore/node_modules/minimatch/minimatch.js
npm ERR! code ENOENT
npm ERR! message ENOENT, open '/usr/local/lib/node_modules/jitsu/node_modules/fstream-npm/node_modules/fstream-ignore/node_modules/minimatch/minimatch.js'
npm ERR! errno {}
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/shawn/npm-debug.log
npm not ok

@mfncooper

This comment has been minimized.

Show comment Hide comment
@mfncooper

mfncooper Sep 26, 2012

Contributor

The key is the "No compatible versions found" messages. The problem is that some of jitsu's dependencies themselves depend on the read package, which requires Node v0.8 or greater. You're using Node v0.6.14. You'll need to upgrade to Node v0.8.x to be able to use jitsu.

Contributor

mfncooper commented Sep 26, 2012

The key is the "No compatible versions found" messages. The problem is that some of jitsu's dependencies themselves depend on the read package, which requires Node v0.8 or greater. You're using Node v0.6.14. You'll need to upgrade to Node v0.8.x to be able to use jitsu.

@mfncooper mfncooper closed this Sep 26, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment