Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP


Better error when package requires newer version of node #2841

vojtajina opened this Issue · 3 comments

3 participants

npm ERR! Error: No compatible version found: testacular@'canary'
npm ERR! Valid install targets:
npm ERR! ["0.0.7","0.0.8","0.0.9","0.0.10","0.0.11","0.0.12","0.0.13","0.0.14","0.0.15","0.0.16","0.0.17"]

This is confusing for people. The package does exist, but it requires newer version of node. It should say something like "This package requires node 0.8.4 or higher. Your version is x. Please upgrade node in order to install this package."

@vojtajina vojtajina referenced this issue in angular/angular-seed

Add testacular conf for E2E tests #28


@vojtajina This is harder than it sounds for edge cases because the version could be something like <0.8.5 && >0.8.7 (if author knows specific ranges don't work.)


Though it should probably mention "no compatible node version found:"

@domenic domenic closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.