This repository has been archived by the owner. It is now read-only.

Better error when package requires newer version of node #2841

Closed
vojtajina opened this Issue Sep 29, 2012 · 3 comments

Comments

Projects
None yet
3 participants
@vojtajina

vojtajina commented Sep 29, 2012

npm ERR! Error: No compatible version found: testacular@'canary'
npm ERR! Valid install targets:
npm ERR! ["0.0.7","0.0.8","0.0.9","0.0.10","0.0.11","0.0.12","0.0.13","0.0.14","0.0.15","0.0.16","0.0.17"]

This is confusing for people. The package does exist, but it requires newer version of node. It should say something like "This package requires node 0.8.4 or higher. Your version is x. Please upgrade node in order to install this package."

@timoxley

This comment has been minimized.

Member

timoxley commented Jan 7, 2014

@vojtajina This is harder than it sounds for edge cases because the version could be something like <0.8.5 && >0.8.7 (if author knows specific ranges don't work.)

@timoxley

This comment has been minimized.

Member

timoxley commented Jan 7, 2014

Though it should probably mention "no compatible node version found:"

@timoxley

This comment has been minimized.

Member

timoxley commented Jan 7, 2014

@domenic domenic closed this Jan 7, 2014

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.