'make install' fails when attempting to install npm on Ubuntu 12.04 LTS #2842

Closed
JLewis604 opened this Issue Sep 29, 2012 · 2 comments

Projects

None yet

2 participants

@JLewis604

1323 verbose unresolvable dependency tree [ 'tap@0.2.6',
1323 verbose unresolvable dependency tree { traverse: '0.6.3' },
1323 verbose unresolvable dependency tree { difflet: '0.2.3' },
1323 verbose unresolvable dependency tree { tap: '0.2.6', THIS_IS_P: true },
1323 verbose unresolvable dependency tree { npm: '1.1.61' },
1323 verbose unresolvable dependency tree {} ]
1324 verbose about to build /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet/node_modules/traverse
1325 info /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet/node_modules/traverse unbuild
1326 verbose from cache /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet/node_modules/traverse/package.json
1327 info preuninstall traverse@0.6.3
1328 info uninstall traverse@0.6.3
1329 verbose false,/home/j/Projects/git-repo/npm/node_modules,/home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet/node_modules unbuild traverse@0.6.3
1330 verbose /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet/node_modules/.bin,[object Object] binRoot
1331 info postuninstall traverse@0.6.3
1332 verbose about to build /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet
1333 info /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet unbuild
1334 verbose from cache /home/j/Projects/git-repo/npm/node_modules/tap/node_modules/difflet/package.json
1335 info preuninstall difflet@0.2.3
1336 info uninstall difflet@0.2.3
1337 verbose false,/home/j/Projects/git-repo/npm/node_modules,/home/j/Projects/git-repo/npm/node_modules/tap/node_modules unbuild difflet@0.2.3
1338 info postuninstall difflet@0.2.3
1339 verbose about to build /home/j/Projects/git-repo/npm/node_modules/tap
1340 info /home/j/Projects/git-repo/npm/node_modules/tap unbuild
1341 verbose from cache /home/j/Projects/git-repo/npm/node_modules/tap/package.json
1342 info preuninstall tap@0.2.6
1343 info uninstall tap@0.2.6
1344 verbose true,/home/j/Projects/git-repo/npm/node_modules,/home/j/Projects/git-repo/npm/node_modules unbuild tap@0.2.6
1345 verbose /home/j/Projects/git-repo/npm/node_modules/.bin,[object Object] binRoot
1346 info postuninstall tap@0.2.6
1347 error cycle Unresolvable cycle detected
1347 error cycle While installing: tap@0.2.6
1347 error cycle Found a pathological dependency case that npm cannot solve.
1347 error cycle Please report this to the package author.
1348 error System Linux 3.2.0-31-generic
1349 error command "node" "/home/j/Projects/git-repo/npm/cli.js" "install"
1350 error cwd /home/j/Projects/git-repo/npm
1351 error node -v v0.6.14
1352 error npm -v 1.1.61
1353 error code ECYCLE
1354 verbose exit [ 1, true ]

Any help provided would be greatly apprecaited. Not sure whats happening. I have attempted to remove node and npm, and reinstalling, but I continue to get errors much like the one posted above.

Thanks for the help in advance...
JL

@JLewis604 JLewis604 closed this Sep 30, 2012
@JLewis604

Oops. thanks again

@malachaifrazier

Where is the fix for this?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment