deprecate doesn't help npm update/npm outdated #3040

Closed
ForbesLindesay opened this Issue Jan 7, 2013 · 2 comments

4 participants

@ForbesLindesay
npm member

It would be great if npm update and npm outdated gave you a warning message if you had modules installed that were deprecated, even if there's no more recent version available. This would fix mishoo/UglifyJS2#89

@destroyerofbuilds

Agreed. The deprecated state of a package should be made apparent to the developer.

@othiym23

This would be a fantastic, simple-to-implement usability improvement, and were someone to put it together, the CLI team be happy to review and merge it. The team isn't going to have the resources to implement this ourselves in the next 6-12 months, though, so I'm putting patch-welcome on this issue and closing it. Thanks for the suggestion, Forbes, and thanks to both of you for your time!

@othiym23 othiym23 closed this Apr 21, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment