Error: ENOENT, chmod #3843

Closed
websocketdev opened this Issue Aug 28, 2013 · 1 comment

Projects

None yet

3 participants

@websocketdev

Tried npm install websockify

Using Node.js v0.10.17 download, OSX 10.8.3, get the following error: (I checked, websockify.js file doesn't get installed, I've tried running with sudo as well, dir permissions are drwxr-xr-x. (Not sure if I should log issue with websockify project)

npm ERR! Error: ENOENT, chmod '/export/node_modules/websockify/websockify.js'
npm ERR! If you need help, you may report this log at:
npm ERR! http://github.com/isaacs/npm/issues
npm ERR! or email it to:
npm ERR! npm-@googlegroups.com

npm ERR! System Darwin 12.3.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "websockify"
npm ERR! cwd /export
npm ERR! node -v v0.10.17
npm ERR! npm -v 1.3.8
npm ERR! path /export/node_modules/websockify/websockify.js
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /export/npm-debug.log
npm ERR! not ok code 0

@timoxley
Member
timoxley commented Jan 9, 2014

@websocketdev This is 100% an issue with websockify, good that you've opened an issue there. The current websockify release 0.5.1 doesn't actually contain websockify.js, thus the ENOENT error.

#4430

@domenic domenic closed this Jan 9, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment