Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Error: ENOENT, lstat '/usr/local/lib/node_modules/gh/node_modules/moment/lang/tzm-la.js' #4295

Closed
marclundgren opened this Issue Dec 11, 2013 · 4 comments

Comments

Projects
None yet
4 participants
root@ubuntu:/home/marc/Downloads/node-v0.10.22# npm -g install gh
npm http GET https://registry.npmjs.org/gh
npm http 200 https://registry.npmjs.org/gh
npm http GET https://registry.npmjs.org/gh/-/gh-1.8.2.tgz
npm http 200 https://registry.npmjs.org/gh/-/gh-1.8.2.tgz
npm http GET https://registry.npmjs.org/async
npm http GET https://registry.npmjs.org/cli-color
npm http GET https://registry.npmjs.org/cli-log
npm http GET https://registry.npmjs.org/copy-paste
npm http GET https://registry.npmjs.org/moment
npm http GET https://registry.npmjs.org/handlebars/1.0.11
npm http GET https://registry.npmjs.org/github
npm http GET https://registry.npmjs.org/inquirer
npm http GET https://registry.npmjs.org/wordwrap
npm http GET https://registry.npmjs.org/nopt
npm http GET https://registry.npmjs.org/open
npm http GET https://registry.npmjs.org/truncate
npm http GET https://registry.npmjs.org/update-notifier
npm http GET https://registry.npmjs.org/userhome
npm http GET https://registry.npmjs.org/which
npm http 200 https://registry.npmjs.org/truncate
npm http GET https://registry.npmjs.org/truncate/-/truncate-1.0.2.tgz
npm http 200 https://registry.npmjs.org/cli-log
npm http 200 https://registry.npmjs.org/userhome
npm http 200 https://registry.npmjs.org/copy-paste
npm http GET https://registry.npmjs.org/cli-log/-/cli-log-0.0.8.tgz
npm http GET https://registry.npmjs.org/userhome/-/userhome-0.1.0.tgz
npm http 200 https://registry.npmjs.org/wordwrap
npm http 200 https://registry.npmjs.org/which
npm http GET https://registry.npmjs.org/copy-paste/-/copy-paste-0.1.0.tgz
npm http GET https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.2.tgz
npm http GET https://registry.npmjs.org/which/-/which-1.0.5.tgz
npm http 200 https://registry.npmjs.org/handlebars/1.0.11
npm http GET https://registry.npmjs.org/handlebars/-/handlebars-1.0.11.tgz
npm http 200 https://registry.npmjs.org/open
npm http GET https://registry.npmjs.org/open/-/open-0.0.4.tgz
npm http 200 https://registry.npmjs.org/github
npm http 200 https://registry.npmjs.org/update-notifier
npm http 200 https://registry.npmjs.org/nopt
npm http GET https://registry.npmjs.org/github/-/github-0.1.12.tgz
npm http GET https://registry.npmjs.org/update-notifier/-/update-notifier-0.1.7.tgz
npm http 200 https://registry.npmjs.org/cli-color
npm http GET https://registry.npmjs.org/nopt/-/nopt-2.1.2.tgz
npm http GET https://registry.npmjs.org/cli-color/-/cli-color-0.2.3.tgz
npm http 200 https://registry.npmjs.org/moment
npm http GET https://registry.npmjs.org/moment/-/moment-2.4.0.tgz
npm http 200 https://registry.npmjs.org/inquirer
npm http 200 https://registry.npmjs.org/truncate/-/truncate-1.0.2.tgz
npm http 200 https://registry.npmjs.org/cli-log/-/cli-log-0.0.8.tgz
npm http GET https://registry.npmjs.org/inquirer/-/inquirer-0.3.5.tgz
npm http 200 https://registry.npmjs.org/wordwrap/-/wordwrap-0.0.2.tgz
npm http 200 https://registry.npmjs.org/which/-/which-1.0.5.tgz
npm http 200 https://registry.npmjs.org/handlebars/-/handlebars-1.0.11.tgz
npm http 200 https://registry.npmjs.org/open/-/open-0.0.4.tgz
npm http 200 https://registry.npmjs.org/github/-/github-0.1.12.tgz
npm http 200 https://registry.npmjs.org/cli-color/-/cli-color-0.2.3.tgz
npm http 200 https://registry.npmjs.org/update-notifier/-/update-notifier-0.1.7.tgz
npm http 200 https://registry.npmjs.org/nopt/-/nopt-2.1.2.tgz
npm http 200 https://registry.npmjs.org/moment/-/moment-2.4.0.tgz
npm http 200 https://registry.npmjs.org/async
npm http GET https://registry.npmjs.org/async/-/async-0.2.9.tgz
npm http 200 https://registry.npmjs.org/inquirer/-/inquirer-0.3.5.tgz
npm http 200 https://registry.npmjs.org/async/-/async-0.2.9.tgz
npm http 200 https://registry.npmjs.org/userhome/-/userhome-0.1.0.tgz
npm http 200 https://registry.npmjs.org/copy-paste/-/copy-paste-0.1.0.tgz
npm http GET https://registry.npmjs.org/configstore
npm http GET https://registry.npmjs.org/semver
npm http GET https://registry.npmjs.org/chalk
npm http GET https://registry.npmjs.org/request
npm http GET https://registry.npmjs.org/execSync
npm http GET https://registry.npmjs.org/abbrev
npm http GET https://registry.npmjs.org/es5-ext
npm http GET https://registry.npmjs.org/memoizee
npm http GET https://registry.npmjs.org/optimist
npm http GET https://registry.npmjs.org/uglify-js
npm http 200 https://registry.npmjs.org/execSync
npm http 200 https://registry.npmjs.org/chalk
npm http 200 https://registry.npmjs.org/abbrev
npm http 200 https://registry.npmjs.org/configstore
npm http GET https://registry.npmjs.org/execSync/-/execSync-1.0.1-pre.tgz
npm http GET https://registry.npmjs.org/chalk/-/chalk-0.2.1.tgz
npm http GET https://registry.npmjs.org/abbrev/-/abbrev-1.0.4.tgz
npm http GET https://registry.npmjs.org/configstore/-/configstore-0.1.6.tgz
npm http GET https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/mute-stream/0.0.3
npm http 200 https://registry.npmjs.org/semver
npm http GET https://registry.npmjs.org/semver/-/semver-2.1.0.tgz
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/gh/node_modules/moment/lang/tzm-la.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm ERR! path /usr/local/lib/node_modules/gh/node_modules/moment/lang/tzm-la.js
npm ERR! fstream_path /usr/local/lib/node_modules/gh/node_modules/moment/lang/tzm-la.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm http 200 https://registry.npmjs.org/es5-ext
npm http 200 https://registry.npmjs.org/execSync/-/execSync-1.0.1-pre.tgz
npm http 200 https://registry.npmjs.org/abbrev/-/abbrev-1.0.4.tgz
npm http 200 https://registry.npmjs.org/request
npm ERR! fetch failed https://registry.npmjs.org/chalk/-/chalk-0.2.1.tgz
npm http 200 https://registry.npmjs.org/configstore/-/configstore-0.1.6.tgz
npm http 200 https://registry.npmjs.org/mute-stream/0.0.3
npm ERR! Error: SSL Error: null
npm ERR!     at Request.onResponse (/usr/local/lib/node_modules/npm/node_modules/request/request.js:645:24)
npm ERR!     at ClientRequest.g (events.js:187:16)
npm ERR!     at ClientRequest.EventEmitter.emit (events.js:98:17)
npm ERR!     at HTTPParser.parserOnIncomingClient (_http_client.js:381:21)
npm ERR!     at HTTPParser.parserOnHeadersComplete (_http_common.js:111:23)
npm ERR!     at TLSSocket.socketOnData (_http_client.js:272:20)
npm ERR!     at TLSSocket.EventEmitter.emit (events.js:98:17)
npm ERR!     at readableAddChunk (_stream_readable.js:156:16)
npm ERR!     at TLSSocket.Readable.push (_stream_readable.js:123:10)
npm ERR!     at TCP.onread (net.js:509:20)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm ERR! code ESSL
npm ERR! TypeError: Property 'onIncoming' of object #<HTTPParser> is not a function
npm ERR!     at HTTPParser.parserOnHeadersComplete (_http_common.js:111:23)
npm ERR!     at TLSSocket.socketOnData (_http_client.js:272:20)
npm ERR!     at TLSSocket.EventEmitter.emit (events.js:98:17)
npm ERR!     at readableAddChunk (_stream_readable.js:156:16)
npm ERR!     at TLSSocket.Readable.push (_stream_readable.js:123:10)
npm ERR!     at TCP.onread (net.js:509:20)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm http GET https://registry.npmjs.org/es5-ext/-/es5-ext-0.9.2.tgz
npm http GET https://registry.npmjs.org/request/-/request-2.27.0.tgz
npm http GET https://registry.npmjs.org/mute-stream/-/mute-stream-0.0.3.tgz
npm http 200 https://registry.npmjs.org/semver/-/semver-2.1.0.tgz
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/gh/node_modules/github/doc/index.html'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm ERR! path /usr/local/lib/node_modules/gh/node_modules/github/doc/index.html
npm ERR! fstream_path /usr/local/lib/node_modules/gh/node_modules/github/doc/index.html
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm http 200 https://registry.npmjs.org/es5-ext/-/es5-ext-0.9.2.tgz
npm http 200 https://registry.npmjs.org/request/-/request-2.27.0.tgz
npm http 200 https://registry.npmjs.org/mute-stream/-/mute-stream-0.0.3.tgz
npm http 200 https://registry.npmjs.org/uglify-js
npm http GET https://registry.npmjs.org/uglify-js/-/uglify-js-1.2.6.tgz
npm http GET https://registry.npmjs.org/temp
npm http 200 https://registry.npmjs.org/uglify-js/-/uglify-js-1.2.6.tgz
npm http 200 https://registry.npmjs.org/temp
npm http GET https://registry.npmjs.org/temp/-/temp-0.5.1.tgz
npm http 200 https://registry.npmjs.org/temp/-/temp-0.5.1.tgz
npm http GET https://registry.npmjs.org/rimraf
npm http 200 https://registry.npmjs.org/rimraf
npm http GET https://registry.npmjs.org/rimraf/-/rimraf-2.1.4.tgz
npm http 200 https://registry.npmjs.org/rimraf/-/rimraf-2.1.4.tgz
npm http GET https://registry.npmjs.org/graceful-fs
npm http 200 https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/graceful-fs/-/graceful-fs-1.2.3.tgz
npm http 200 https://registry.npmjs.org/graceful-fs/-/graceful-fs-1.2.3.tgz

> execSync@1.0.1-pre install /usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync
> node-gyp rebuild

gyp WARN EACCES user "root" does not have permission to access the dev dir "/root/.node-gyp/0.11.9"
gyp WARN EACCES attempting to reinstall using temporary dev dir "/usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync/.node-gyp"
gyp http GET http://nodejs.org/dist/v0.11.9/node-v0.11.9.tar.gz
gyp http 200 http://nodejs.org/dist/v0.11.9/node-v0.11.9.tar.gz
make: Entering directory `/usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync/build'
  CXX(target) Release/obj.target/shell/src/shell.o
../src/shell.cpp:138:26: error: ‘Arguments’ does not name a type
../src/shell.cpp:138:37: error: ISO C++ forbids declaration of ‘args’ with no type [-fpermissive]
/usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync/.node-gyp/0.11.9/deps/v8/include/v8.h: In function ‘v8::Handle<v8::Value> Exec(const int&)’:
/usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync/.node-gyp/0.11.9/deps/v8/include/v8.h:768:13: error: ‘v8::HandleScope::HandleScope()’ is private
../src/shell.cpp:139:17: error: within this context
../src/shell.cpp:141:14: error: request for member ‘Length’ in ‘args’, which is of non-class type ‘const int’
../src/shell.cpp:147:31: error: invalid types ‘const int[int]’ for array subscript
../src/shell.cpp: In function ‘void RegisterModule(v8::Handle<v8::Object>)’:
../src/shell.cpp:156:39: error: invalid conversion from ‘v8::Handle<v8::Value> (*)(const int&)’ to ‘v8::FunctionCallback {aka void (*)(const v8::FunctionCallbackInfo<v8::Value>&)}’ [-fpermissive]
/usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync/.node-gyp/0.11.9/deps/v8/include/v8.h:3346:34: error:   initializing argument 1 of ‘static v8::Local<v8::FunctionTemplate> v8::FunctionTemplate::New(v8::FunctionCallback, v8::Handle<v8::Value>, v8::Handle<v8::Signature>, int)’ [-fpermissive]
../src/shell.cpp: In function ‘void child(const char*)’:
../src/shell.cpp:69:11: warning: ignoring return value of ‘int dup(int)’, declared with attribute warn_unused_result [-Wunused-result]
../src/shell.cpp:71:11: warning: ignoring return value of ‘int dup(int)’, declared with attribute warn_unused_result [-Wunused-result]
make: *** [Release/obj.target/shell/src/shell.o] Error 1
make: Leaving directory `/usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync/build'
gyp ERR! build error 
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:267:23)
gyp ERR! stack     at ChildProcess.EventEmitter.emit (events.js:101:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:827:12)
gyp ERR! System Linux 3.8.0-34-generic
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/gh/node_modules/copy-paste/node_modules/execSync
gyp ERR! node -v v0.11.9
gyp ERR! node-gyp -v v0.12.1
gyp ERR! not ok 
npm WARN optional dep failed, continuing execSync@1.0.1-pre
npm http GET https://registry.npmjs.org/memoizee
npm http GET https://registry.npmjs.org/chalk/-/chalk-0.2.1.tgz
npm http GET https://registry.npmjs.org/lodash
npm http 200 https://registry.npmjs.org/chalk/-/chalk-0.2.1.tgz
npm http GET https://registry.npmjs.org/has-color
npm http GET https://registry.npmjs.org/ansi-styles
npm http GET https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/js-yaml
npm http GET https://registry.npmjs.org/osenv/0.0.3
npm ERR! Error: stream.push() after EOF
npm ERR!     at readableAddChunk (_stream_readable.js:142:15)
npm ERR!     at IncomingMessage.Readable.push (_stream_readable.js:123:10)
npm ERR!     at HTTPParser.parserOnBody (_http_common.js:132:22)
npm ERR!     at TLSSocket.socketOnData (_http_client.js:272:20)
npm ERR!     at TLSSocket.EventEmitter.emit (events.js:98:17)
npm ERR!     at readableAddChunk (_stream_readable.js:156:16)
npm ERR!     at TLSSocket.Readable.push (_stream_readable.js:123:10)
npm ERR!     at TCP.onread (net.js:509:20)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm http 200 https://registry.npmjs.org/memoizee
npm http GET https://registry.npmjs.org/graceful-fs/-/graceful-fs-2.0.1.tgz
npm http GET https://registry.npmjs.org/memoizee/-/memoizee-0.2.6.tgz
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/gh/node_modules/update-notifier/node_modules/request/index.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm ERR! path /usr/local/lib/node_modules/gh/node_modules/update-notifier/node_modules/request/index.js
npm ERR! fstream_path /usr/local/lib/node_modules/gh/node_modules/update-notifier/node_modules/request/index.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/gh/node_modules/update-notifier/node_modules/semver/semver.browser.js'
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 3.8.0-34-generic
npm ERR! command "/usr/local/bin/node" "/usr/local/bin/npm" "-g" "install" "gh"
npm ERR! cwd /home/marc/Downloads/node-v0.10.22
npm ERR! node -v v0.11.9
npm ERR! npm -v 1.3.15
npm ERR! path /usr/local/lib/node_modules/gh/node_modules/update-notifier/node_modules/semver/semver.browser.js
npm ERR! fstream_path /usr/local/lib/node_modules/gh/node_modules/update-notifier/node_modules/semver/semver.browser.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm http 200 https://registry.npmjs.org/osenv/0.0.3
npm http GET https://registry.npmjs.org/osenv/-/osenv-0.0.3.tgz
npm http 200 https://registry.npmjs.org/ansi-styles
npm http 200 https://registry.npmjs.org/js-yaml
npm ERR! registry error parsing json
npm http GET https://registry.npmjs.org/ansi-styles/-/ansi-styles-0.2.0.tgz
npm http 200 https://registry.npmjs.org/memoizee/-/memoizee-0.2.6.tgz
npm http 200 https://registry.npmjs.org/graceful-fs/-/graceful-fs-2.0.1.tgz
npm http 200 https://registry.npmjs.org/osenv/-/osenv-0.0.3.tgz
npm http 200 https://registry.npmjs.org/ansi-styles/-/ansi-styles-0.2.0.tgz
npm http GET https://registry.npmjs.org/next-tick
npm http GET https://registry.npmjs.org/event-emitter
npm http 200 https://registry.npmjs.org/next-tick
npm http GET https://registry.npmjs.org/next-tick/-/next-tick-0.1.0.tgz
npm http 200 https://registry.npmjs.org/event-emitter
npm http GET https://registry.npmjs.org/event-emitter/-/event-emitter-0.2.2.tgz
npm http 200 https://registry.npmjs.org/next-tick/-/next-tick-0.1.0.tgz
npm http 200 https://registry.npmjs.org/event-emitter/-/event-emitter-0.2.2.tgz
npm http GET https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/mkdirp
npm http 200 https://registry.npmjs.org/mkdirp
npm http GET https://registry.npmjs.org/mkdirp/-/mkdirp-0.3.5.tgz
npm http 200 https://registry.npmjs.org/mkdirp/-/mkdirp-0.3.5.tgz
npm http 200 https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/lodash/-/lodash-2.4.1.tgz
npm http 200 https://registry.npmjs.org/lodash/-/lodash-2.4.1.tgz
npm http GET https://registry.npmjs.org/lodash
npm http 200 https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/lodash/-/lodash-1.2.1.tgz
npm http 200 https://registry.npmjs.org/lodash/-/lodash-1.2.1.tgz
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/marc/Downloads/node-v0.10.22/npm-debug.log
npm ERR! not ok code 0

@iarna iarna added the support label Oct 3, 2014

Contributor

smikes commented Nov 19, 2014

Is this still a problem for you?

This looks like it may have been caused by a race condition in npm install. Several of those have been fixed since 1.3.15, and the latest npm is 2.1.8

Can you try updating your npm to see if the problem still exists with the latest version?

$ sudo npm install -g npm

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and re-open it!)

Thanks!

thanks @smikes, i'll check this out on a fresh ubuntu install

Contributor

othiym23 commented Nov 26, 2014

Please note that the versions of Node and npm packaged by Debian and Ubuntu are badly out of date most of the time, so consider using newer .debs to check this out.

Contributor

othiym23 commented Dec 5, 2014

Closing as resolved / abandoned. If you find that this issue still exists after trying a newer version of npm, please open a new issue. Thanks!

@othiym23 othiym23 closed this Dec 5, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment