Skip to content

npm update => TypeError: Cannot read property 'from' of undefined #4314

Closed
boustanihani opened this Issue Dec 14, 2013 · 3 comments

4 participants

@boustanihani

Hi,

I am getting this error when calling npm updat. i am using Cloud9, hope someone could help =>

npm ERR! TypeError: Cannot read property 'from' of undefined
npm ERR!     at /usr/libexec/openshift/cartridges/c9-0.1/root/lib/node_modules/npm/lib/outdated.js:159:36
npm ERR!     at /usr/libexec/openshift/cartridges/c9-0.1/root/lib/node_modules/npm/lib/cache.js:591:30
npm ERR!     at /usr/libexec/openshift/cartridges/c9-0.1/root/lib/node_modules/npm/node_modules/lockfile/lockfile.js:55:41
npm ERR!     at Object.oncomplete (fs.js:107:15)
npm ERR! If you need help, you may report this log at:
npm ERR!     <http://github.com/isaacs/npm/issues>
npm ERR! or email it to:
npm ERR!     <npm-@googlegroups.com>

npm ERR! System Linux 2.6.32-431.el6oso.bz844450.x86_64
npm ERR! command "/usr/libexec/openshift/cartridges/c9-0.1/root/bin/node-openshift-v10" "/usr/libexec/openshift/cartridges/c9-0.1/root/lib/node_modules/npm/bin/npm-cli.js" "update"
npm ERR! cwd /var/lib/stickshift/5253e0d64382eca2bb000007/app-root/data/640028
npm ERR! node -v v0.10.22
npm ERR! npm -v 1.3.8
npm ERR! type non_object_property_load
npm ERR! 
npm ERR! not ok code 0

regads
Hani

@iarna iarna added the support label Oct 3, 2014
@smikes
smikes commented Nov 19, 2014

Is this still a problem for you?

There have been a lot of improvements to npm -- especially around conflicts and race conditions during install -- since 1.3.8. Can you try updating your npm installation?

To update npm, run npm -g install npm@latest

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and re-open it!)

Thanks!

@othiym23

Closing as abandoned.

@othiym23 othiym23 closed this Nov 26, 2014
@boustanihani

Sorry I must have missed your reply, I am not having this error any more, everything is fine.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.