Skip to content

Appfog npm-shrinkwrap.json unable to install modules #4397

Closed
cooolbasha opened this Issue Dec 30, 2013 · 2 comments

3 participants

@cooolbasha

have node 0.10.22 on appfog but the npm seems to be old. it is throwing an error message as not able to install. The npm-shrinwrap.json is from npm 1.3.9(attached below the message)

Installing dependencies. Node version 0.10.22 Installing bcrypt@bcrypt@ from registry

Package is not found in npm registry bcrypt@bcrypt@

Failed getting the requested package: bcrypt@bcrypt@

{
  "name": "application-name",
  "version": "0.0.1",
  "dependencies": {
    "bcrypt": {
      "version": "0.7.7",
      "from": "bcrypt@",
      "dependencies": {
        "bindings": {
          "version": "1.0.0",
          "from": "bindings@1.0.0"
        }
      }
    }
}
@pateljatin

just wondering if anybody found a solution to this - I'm running in to the same problem now on appfog with node10 - I already tried npm shrinkwrap but still the same error.

uncaughtException: Unable to load shared library /mnt/var/vcap.local/dea/apps/demo48bricks-0-51c1bfca54b6b950cbe40ee793ba97a7/app/node_modules/bcrypt/build/Release/bcrypt_lib.node
Thu Jul 03 2014 15:38:55 GMT+0000 (UTC) - error: Error: Unable to load shared library /mnt/var/vcap.local/dea/apps/demo48bricks-0-51c1bfca54b6b950cbe40ee793ba97a7/app/node_modules/bcrypt/build/Release/bcrypt_lib.node
    at Object..node (module.js:472:11)
    at Module.load (module.js:348:31)
    at Function._load (module.js:308:12)
    at Module.require (module.js:354:17)
    at require (module.js:370:17)
    at bindings (/mnt/var/vcap.local/dea/apps/demo48bricks-0-51c1bfca54b6b950cbe40ee793ba97a7/app/node_modules/bcrypt/node_modules/bindings/bindings.js:74:15)
    at Object.<anonymous> (/mnt/var/vcap.local/dea/apps/demo48bricks-0-51c1bfca54b6b950cbe40ee793ba97a7/app/node_modules/bcrypt/bcrypt.js:3:34)
    at Module._compile (module.js:441:26)
    at Object..js (module.js:459:10)
    at Module.load (module.js:348:31)
@othiym23 othiym23 added the support label Sep 22, 2014
@othiym23

I'd love to be able to help you two, but I think this is a question for Appfog support, not the npm team.

@othiym23 othiym23 closed this Sep 22, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.