Skip to content

Error installing dependency packages. #4659

Closed
leehongfay opened this Issue Feb 12, 2014 · 2 comments

3 participants

@leehongfay
npm ERR! Error: ENOENT, chown '/usr/local/lib/node_modules/wavelet-hub/node_modules/adaro/node_modules'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/isaacs/npm/issues>

npm ERR! System Linux 3.4.76-65.111.amzn1.x86_64
npm ERR! command "node" "/usr/local/bin/npm" "install" "-d" "-g"
npm ERR! cwd /home/node/wavelet-hub
npm ERR! node -v v0.11.12-pre
npm ERR! npm -v 1.3.26
npm ERR! path /usr/local/lib/node_modules/wavelet-hub/node_modules/adaro/node_modules
npm ERR! fstream_path /usr/local/lib/node_modules/wavelet-hub/node_modules/adaro/node_modules/core-util-is
npm ERR! fstream_type Directory
npm ERR! fstream_class DirWriter
npm ERR! fstream_finish_call setupMadeDir
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack end (/usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:319:21)
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:336:20
npm ERR! fstream_stack next (/usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:366:20)
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:133:7
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/wavelet-hub/node_modules/mongoose/lib/types/array.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/isaacs/npm/issues>

npm ERR! System Linux 3.4.76-65.111.amzn1.x86_64
npm ERR! command "node" "/usr/local/bin/npm" "install" "-d" "-g"
npm ERR! cwd /home/node/wavelet-hub
npm ERR! node -v v0.11.12-pre
npm ERR! npm -v 1.3.26
npm ERR! path /usr/local/lib/node_modules/wavelet-hub/node_modules/mongoose/lib/types/array.js
npm ERR! fstream_path /usr/local/lib/node_modules/wavelet-hub/node_modules/mongoose/lib/types/array.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm info /usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-helpers unbuild
npm ERR! error rolling back Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-helpers/test'
npm ERR! error rolling back  wavelet-hub@0.1.0 { [Error: ENOTEMPTY, rmdir '/usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-helpers/test']
npm ERR! error rolling back   stack: 'Error: ENOTEMPTY, rmdir \'/usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-helpers/test\'',
npm ERR! error rolling back   errno: -39,
npm ERR! error rolling back   code: 'ENOTEMPTY',
npm ERR! error rolling back   path: '/usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-helpers/test' }
npm ERR! bcrypt@0.7.7 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the bcrypt@0.7.7 install script.
npm ERR! This is most likely a problem with the bcrypt package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls bcrypt
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 3.4.76-65.111.amzn1.x86_64
npm ERR! command "node" "/usr/local/bin/npm" "install" "-d" "-g"
npm ERR! cwd /home/node/wavelet-hub
npm ERR! node -v v0.11.12-pre
npm ERR! npm -v 1.3.26
npm ERR! code ELIFECYCLE
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/wavelet-hub/node_modules/less/dist/less-1.1.0.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/isaacs/npm/issues>

npm ERR! System Linux 3.4.76-65.111.amzn1.x86_64
npm ERR! command "node" "/usr/local/bin/npm" "install" "-d" "-g"
npm ERR! cwd /home/node/wavelet-hub
npm ERR! node -v v0.11.12-pre
npm ERR! npm -v 1.3.26
npm ERR! path /usr/local/lib/node_modules/wavelet-hub/node_modules/less/dist/less-1.1.0.js
npm ERR! fstream_path /usr/local/lib/node_modules/wavelet-hub/node_modules/less/dist/less-1.1.0.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
npm info install pkginfo@0.2.3 into /usr/local/lib/node_modules/wavelet-hub/node_modules/passport-local
npm info install passport@0.1.18 into /usr/local/lib/node_modules/wavelet-hub/node_modules/passport-local
npm info installOne pkginfo@0.2.3
npm info installOne passport@0.1.18
npm info /usr/local/lib/node_modules/wavelet-hub/node_modules/passport-local/node_modules/pkginfo unbuild
npm info /usr/local/lib/node_modules/wavelet-hub/node_modules/passport-local/node_modules/passport unbuild
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-linkedin/dist/dust-full-1.2.3.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/isaacs/npm/issues>

npm ERR! System Linux 3.4.76-65.111.amzn1.x86_64
npm ERR! command "node" "/usr/local/bin/npm" "install" "-d" "-g"
npm ERR! cwd /home/node/wavelet-hub
npm ERR! node -v v0.11.12-pre
npm ERR! npm -v 1.3.26
npm ERR! path /usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-linkedin/dist/dust-full-1.2.3.js
npm ERR! fstream_path /usr/local/lib/node_modules/wavelet-hub/node_modules/dustjs-linkedin/dist/dust-full-1.2.3.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:97:15)
@othiym23 othiym23 added the support label Sep 26, 2014
@smikes
smikes commented Nov 26, 2014

Is this still a problem for you?

There have been a lot of improvements to npm -- especially around conflicts and race conditions during install -- since 1.3.26. Can you try updating your npm installation?

To update npm, run sudo npm -g install npm@latest

You may want to check out our suggestions for keeping up to date with the latest node (current is 0.10.33) on various Linux distributions - https://github.com/npm/npm/wiki/Troubleshooting#updating-node-on-linux

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and re-open it!)

Thanks!

@othiym23
othiym23 commented Dec 5, 2014

Closing as abandoned. Open a new issue if you encounter this behavior again!

@othiym23 othiym23 closed this Dec 5, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.