Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Not able to install yo and generators #5196

Closed
ladvishal1985 opened this Issue · 2 comments

5 participants

@ladvishal1985

I have tried clearing the cache. But still I am unable to install yo.

5994 info postinstall lodash.now@2.4.1
5995 verbose about to build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\lodash.debounce\node_modules\lodash.isobject
5996 info build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\lodash.debounce\node_modules\lodash.isobject
5997 verbose linkStuff [ true,
5997 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules',
5997 verbose linkStuff   false,
5997 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules\\yo\\node_modules\\insight\\node_modules\\lodash.debounce\\node_modules' ]
5998 info linkStuff lodash.isobject@2.4.1
5999 verbose readDependencies using package.json deps
6000 silly lockFile 7cc786ab--configstore-node-modules-mkdirp tar://C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\update-notifier\node_modules\configstore\node_modules\mkdirp
6001 silly lockFile 7cc786ab--configstore-node-modules-mkdirp tar://C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\update-notifier\node_modules\configstore\node_modules\mkdirp
6002 verbose readDependencies using package.json deps
6003 silly resolved []
6004 verbose about to build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\update-notifier\node_modules\configstore\node_modules\uuid
6005 info build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\update-notifier\node_modules\configstore\node_modules\uuid
6006 verbose linkStuff [ true,
6006 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules',
6006 verbose linkStuff   false,
6006 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules\\yo\\node_modules\\update-notifier\\node_modules\\configstore\\node_modules' ]
6007 info linkStuff uuid@1.4.1
6008 verbose linkBins lodash.isobject@2.4.1
6009 verbose linkMans lodash.isobject@2.4.1
6010 verbose rebuildBundles lodash.isobject@2.4.1
6011 silly lockFile 29f723bf-m-cache-mkdirp-0-3-5-package-tgz tar://C:\Users\vishal\AppData\Roaming\npm-cache\mkdirp\0.3.5\package.tgz
6012 silly lockFile 29f723bf-m-cache-mkdirp-0-3-5-package-tgz tar://C:\Users\vishal\AppData\Roaming\npm-cache\mkdirp\0.3.5\package.tgz
6013 verbose rebuildBundles [ 'lodash._objecttypes' ]
6014 info install lodash.isobject@2.4.1
6015 verbose linkBins uuid@1.4.1
6016 verbose linkMans uuid@1.4.1
6017 verbose rebuildBundles uuid@1.4.1
6018 info install uuid@1.4.1
6019 info postinstall lodash.isobject@2.4.1
6020 info postinstall uuid@1.4.1
6021 verbose about to build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\lodash.debounce
6022 info build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\lodash.debounce
6023 verbose linkStuff [ true,
6023 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules',
6023 verbose linkStuff   false,
6023 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules\\yo\\node_modules\\insight\\node_modules' ]
6024 info linkStuff lodash.debounce@2.4.1
6025 info preinstall mkdirp@0.3.5
6026 verbose linkBins lodash.debounce@2.4.1
6027 verbose linkMans lodash.debounce@2.4.1
6028 verbose rebuildBundles lodash.debounce@2.4.1
6029 verbose rebuildBundles [ 'lodash.isobject', 'lodash.now' ]
6030 info install lodash.debounce@2.4.1
6031 verbose readDependencies using package.json deps
6032 info postinstall lodash.debounce@2.4.1
6033 verbose readDependencies using package.json deps
6034 silly resolved []
6035 verbose about to build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\update-notifier\node_modules\configstore\node_modules\mkdirp
6036 info build C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\update-notifier\node_modules\configstore\node_modules\mkdirp
6037 verbose linkStuff [ true,
6037 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules',
6037 verbose linkStuff   false,
6037 verbose linkStuff   'C:\\Users\\vishal\\AppData\\Roaming\\npm\\node_modules\\yo\\node_modules\\update-notifier\\node_modules\\configstore\\node_modules' ]
6038 info linkStuff mkdirp@0.3.5
6039 verbose linkBins mkdirp@0.3.5
6040 verbose linkMans mkdirp@0.3.5
6041 verbose rebuildBundles mkdirp@0.3.5
6042 info install mkdirp@0.3.5
6043 info postinstall mkdirp@0.3.5
6044 error Error: ENOENT, chmod 'C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\configstore\node_modules\js-yaml\lib\js-yaml\type\seq.js'
6045 error If you need help, you may report this *entire* log,
6045 error including the npm and node versions, at:
6045 error     <http://github.com/npm/npm/issues>
6046 error System Windows_NT 6.1.7600
6047 error command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "yo"
6048 error cwd C:\Users\vishal\experiments
6049 error node -v v0.10.28
6050 error npm -v 1.4.9
6051 error path C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\configstore\node_modules\js-yaml\lib\js-yaml\type\seq.js
6052 error fstream_path C:\Users\vishal\AppData\Roaming\npm\node_modules\yo\node_modules\insight\node_modules\configstore\node_modules\js-yaml\lib\js-yaml\type\seq.js
6053 error fstream_type File
6054 error fstream_class FileWriter
6055 error fstream_finish_call chmod
6056 error code ENOENT
6057 error errno 34
6058 error fstream_stack C:\Program Files\nodejs\node_modules\npm\node_modules\fstream\lib\writer.js:305:19
6058 error fstream_stack Object.oncomplete (fs.js:107:15)
6059 verbose exit [ 34, true ]
@smikes

Is this still a problem for you?

If so, try the following steps:

  1. update to the latest node (0.10.33)
  2. Follow the instructions for upgrading NPM on windows ( https://github.com/npm/npm/wiki/Troubleshooting#upgrading-on-windows )
  3. now try installing yo
@iarna
Owner

We haven’t heard anything from you, so I’m going to close this ticket and hope you've resolved your problem. If you’re still having problems please open a new ticket. Thanks!

@iarna iarna closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.