Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

ERR! #5457

Closed
Winterwolf opened this Issue Jun 10, 2014 · 3 comments

Comments

Projects
None yet
3 participants
D:\Temp\test>npm install express
npm http GET https://registry.npmjs.org/express
npm http 304 https://registry.npmjs.org/express
npm http GET https://registry.npmjs.org/accepts
npm http GET https://registry.npmjs.org/debug
npm http GET https://registry.npmjs.org/escape-html
npm http GET https://registry.npmjs.org/methods
npm http GET https://registry.npmjs.org/buffer-crc32
npm http GET https://registry.npmjs.org/proxy-addr
npm http GET https://registry.npmjs.org/parseurl
npm http GET https://registry.npmjs.org/range-parser
npm http GET https://registry.npmjs.org/type-is
npm http GET https://registry.npmjs.org/serve-static
npm http GET https://registry.npmjs.org/send
npm http GET https://registry.npmjs.org/cookie
npm http GET https://registry.npmjs.org/vary
npm http GET https://registry.npmjs.org/fresh
npm http GET https://registry.npmjs.org/cookie-signature
npm http GET https://registry.npmjs.org/utils-merge
npm http GET https://registry.npmjs.org/merge-descriptors
npm http GET https://registry.npmjs.org/qs
npm http GET https://registry.npmjs.org/path-to-regexp
npm http 304 https://registry.npmjs.org/debug
npm http 304 https://registry.npmjs.org/buffer-crc32
npm http 304 https://registry.npmjs.org/methods
npm http 304 https://registry.npmjs.org/accepts
npm http 304 https://registry.npmjs.org/escape-html
npm http 304 https://registry.npmjs.org/range-parser
npm http 304 https://registry.npmjs.org/proxy-addr
npm http 304 https://registry.npmjs.org/parseurl
npm http 304 https://registry.npmjs.org/serve-static
npm http 304 https://registry.npmjs.org/type-is
npm http 304 https://registry.npmjs.org/cookie
npm http 304 https://registry.npmjs.org/send
npm http 304 https://registry.npmjs.org/vary
npm http 304 https://registry.npmjs.org/fresh
npm http 304 https://registry.npmjs.org/qs
npm http 304 https://registry.npmjs.org/cookie-signature
npm http 304 https://registry.npmjs.org/merge-descriptors
npm http 304 https://registry.npmjs.org/utils-merge
npm http 304 https://registry.npmjs.org/path-to-regexp
npm http GET https://registry.npmjs.org/mime-types
npm http GET https://registry.npmjs.org/negotiator
npm http GET https://registry.npmjs.org/mime
npm http GET https://registry.npmjs.org/ipaddr.js
npm http GET https://registry.npmjs.org/finished
npm http GET https://registry.npmjs.org/mime
npm http GET https://registry.npmjs.org/ms
npm http 304 https://registry.npmjs.org/negotiator
npm http 304 https://registry.npmjs.org/mime
npm http 304 https://registry.npmjs.org/ipaddr.js
npm http 304 https://registry.npmjs.org/finished
npm http 304 https://registry.npmjs.org/mime-types
npm http 304 https://registry.npmjs.org/mime
npm ERR! Error: ENOENT, lstat 'D:\Temp\test\node_modules\express\node_modules\se
nd\node_modules\finished\index.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Program Files (x86)\\nodejs\\\\node.exe" "C:\\Program File
s (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "express"
npm ERR! cwd D:\Temp\test
npm ERR! node -v v0.10.28
npm ERR! npm -v 1.4.9
npm ERR! path D:\Temp\test\node_modules\express\node_modules\send\node_modules\f
inished\index.js
npm ERR! fstream_path D:\Temp\test\node_modules\express\node_modules\send\node_m
odules\finished\index.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack C:\Program Files (x86)\nodejs\node_modules\npm\node_modul
es\fstream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http 304 https://registry.npmjs.org/ms
npm ERR! Error: UNKNOWN, open 'C:\Users\Winterwolf\AppData\Roaming\npm-cache\mim
e\1.2.11\package\package.json'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Program Files (x86)\\nodejs\\\\node.exe" "C:\\Program File
s (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "express"
npm ERR! cwd D:\Temp\test
npm ERR! node -v v0.10.28
npm ERR! npm -v 1.4.9
npm ERR! path C:\Users\Winterwolf\AppData\Roaming\npm-cache\mime\1.2.11\package\
package.json
npm ERR! code UNKNOWN
npm ERR! errno -1
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     D:\Temp\test\npm-debug.log
npm ERR! not ok code 0
Contributor

othiym23 commented Jun 10, 2014

This is another instance of #5453. There is a workaround, which is just to try to run npm install express again. Eventually, it should install successfully.

I'm using the following :
current: {"node":"v0.10.29","npm":"1.4.14"})

It started giving the same error as described above.
Was working well a few hours back.

@othiym23 othiym23 added the support label Sep 17, 2014

Contributor

othiym23 commented Sep 17, 2014

I believe that as of the resolution of #6043, we've fixed almost all of the underlying causes for this bug. Please see that issue for details on the bug as well as instructions on how to install a fixed version of npm. Thanks for your patience!

@othiym23 othiym23 closed this Sep 17, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment