Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Karma - Error: shasum check failed for #5488

michaelsync opened this Issue · 3 comments

4 participants


As I don't have VS 2010, I am using this command to install Karma

$ npm -g install karma --msvs_version=2013

But got the following error.

validation.vcxproj -> C:\Users\Michael\AppData\Roaming\npm\node_modules\karma
pm http 304
pm ERR! Error: shasum check failed for C:\Users\Michael\AppData\Local\Temp\npm-
pm ERR! Expected: a567c2af000ad22dc8f2a653d91978ae1f5316f4
pm ERR! Actual:   4a5c9ff38c379a4fa3dee9c12e7ee222e7d15eb6
pm ERR! From:
pm ERR!     at c:\Program Files (x86)\nodejs\node_modules\npm\node_modules\sha\
pm ERR!     at ReadStream.<anonymous> (c:\Program Files (x86)\nodejs\node_modul
pm ERR!     at ReadStream.EventEmitter.emit (events.js:117:20)
pm ERR!     at _stream_readable.js:919:16
pm ERR!     at process._tickCallback (node.js:419:13)
pm ERR! If you need help, you may report this *entire* log,
pm ERR! including the npm and node versions, at:
pm ERR!     <>

pm ERR! System Windows_NT 6.2.9200
pm ERR! command "c:\\Program Files (x86)\\nodejs\\node.exe" "c:\\Program Files
x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "-g" "install" "karma" "--msv
pm ERR! cwd c:\Users\Michael\Documents\GitHub\MyProject
pm ERR! node -v v0.10.28
pm ERR! npm -v 1.4.9
pm ERR!
pm ERR! Additional logging details can be found in:

Additional Information.

Window 8
VS 2012 and VS 2013
npm -v 1.4.9
node -v v0.10.28

Any help would be appreciated.


I tested it on Windows 7 and it works.

Is it something to do with Windows 8?


The slow internet connection? Because the error is about checksum and if the download file is not completed or corrupted then we might get that error?


Is this still a problem for you?

This looks like it might have been a transient registry problem, possibly resulting in an incorrect file being cached. npm cache clean sometimes fixes these problems.

There have been a lot of improvements to npm -- especially around conflicts and race conditions during install -- since 1.4.9. Can you try updating your npm installation?

To update npm on Windows, follow the instructions here:

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and open a new issue!)



Closing as resolved / abandoned.

@othiym23 othiym23 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.