Skip to content


Subversion checkout URL

You can clone with
Download ZIP


Getting error when trying to install a package #5516

simondavies opened this Issue · 3 comments

4 participants


when i typed in gulp i goto the message that i require gulp-util, but the whole thing was working earlier. So i did the normal install but came across a vat of errors.

Error: ENOENT, utime ‘……/node_modules/gulp-util/node_modules/lodash.template/node_modules/lodash.escape/node_modules/lodash._escapehtmlchar/node_modules/lodash._htmlescapes/

command "node" "/usr/local/bin/npm" "install" "gulp-util" "--save-dev"
node -v v0.10.28
npm -v 1.4.9
errno 34
fstream_stack /usr/local/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Failed to parse json
npm ERR! Unexpected end of input
npm ERR! File: /Users/PremierPR/.npm/object-keys/0.4.0/package/package.json
npm ERR! Failed to parse package.json data.
npm ERR! package.json must be actual JSON, not just JavaScript

now this is preventing me form continuing, any ideas. The initiator of this was after a npm update call.


Looks like you have a bad package in cache. npm cache clear object-keys and try again.

@othiym23 othiym23 added support and removed troubleshooting labels

What @terinjokes said, and then upgrade to npm@2.0.0, which fixes a bunch of the issues that could have led to that cache corruption occurring in the first place.

@othiym23 othiym23 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.