unable to install ember-cli using npm in ubuntu 14.04 LTS #5615

Closed
venkatesh3007 opened this Issue Jul 3, 2014 · 3 comments

Projects

None yet

4 participants

@venkatesh3007

I am getting the following error while trying to install ember-cli using npm.

18034 error Error: ENOENT, lstat '/usr/local/lib/node_modules/ember-cli/node_modules/lodash-node/compat/internals/baseDifference.js'
18035 error If you need help, you may report this log at:
18035 error     <http://github.com/isaacs/npm/issues>
18035 error or email it to:
18035 error     <npm-@googlegroups.com>
18036 error System Linux 3.13.0-24-generic
18037 error command "/usr/bin/nodejs" "/usr/bin/npm" "install" "-g" "ember-cli"
18038 error cwd /root
18039 error node -v v0.10.25
18040 error npm -v 1.3.10
18041 error path /usr/local/lib/node_modules/ember-cli/node_modules/lodash-node/compat/internals/baseDifference.js
18042 error fstream_path /usr/local/lib/node_modules/ember-cli/node_modules/lodash-node/compat/internals/baseDifference.js
18043 error fstream_type File
18044 error fstream_class FileWriter
18045 error code ENOENT
18046 error errno 34
18047 error fstream_stack /usr/lib/nodejs/fstream/lib/writer.js:284:26
18047 error fstream_stack Object.oncomplete (fs.js:107:15)
@iarna iarna added the support label Sep 19, 2014
@smikes
Contributor
smikes commented Nov 20, 2014

Is this still a problem for you?

There have been a lot of improvements to npm -- especially around conflicts and race conditions during install -- since 1.3.10. Can you try updating your npm installation?

To update npm, run npm -g install npm@latest

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and re-open it!)

Thanks!

@venkatesh3007

I don't have any issue now. It's working great.

@mshafivk

Do the following things:
First Remove node using following command
$ rm -rf ~/.npm ~/.nvm
Use NVM to manage node version.
$ curl https://raw.githubusercontent.com/creationix/nvm/v0.17.1/install.sh | bash
$ source ~/.nvm/nvm.sh
Install stable version of node
$ nvm install 0.12.1
$ nvm use 0.12.1
$nvm alias default 0.12.1
After this you can successfully use the following command
$ npm install -g ember-cli
Please install watchman, bower etc
Now you can create a new ember project without any issues

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment