Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Bower won't install globally on OS X #5732

Closed
kdbanman opened this Issue · 5 comments

6 participants

@kdbanman

I'm on OS X 10.8.5, running node 0.10.11 and npm 1.2.30. Trying to globally install bower with this command:

sudo npm install -g bower

But I'm consistently getting this in my npm-debug.log:

2872 error Error: ENOENT, lstat 

'/usr/local/share/npm/lib/node_modules/bower/node_modules/semver/semver.browser.js'
2873 error If you need help, you may report this log at:
2873 error     <http://github.com/isaacs/npm/issues>
2873 error or email it to:
2873 error     <npm-@googlegroups.com>
2874 error System Darwin 12.5.0
2875 error command "/usr/local/Cellar/node/0.10.11/bin/node" "/usr/local/bin/npm" "install" "-g" "bower"
2876 error cwd /Users/kdbanman
2877 error node -v v0.10.11
2878 error npm -v 1.2.30
2879 error path /usr/local/share/npm/lib/node_modules/bower/node_modules/semver/semver.browser.js
2880 error fstream_path /usr/local/share/npm/lib/node_modules/bower/node_modules/semver/semver.browser.js
2881 error fstream_type File
2882 error fstream_class FileWriter
2883 error code ENOENT
2884 error errno 34
2885 error fstream_stack /usr/local/Cellar/node/0.10.11/lib/node_modules/npm/node_modules/fstream/lib/writer.js:284:26
2885 error fstream_stack Object.oncomplete (fs.js:107:15)

Any help would be appreciated :)

@timoxley
Collaborator

not sure but npm@1.2.30 is rather old, maybe try again after installing the latest stable:

npm install npm -g
@tonyjessup

I'm getting the same error trying to install bower globally. I just installed sass via npm no problem but with bower I get these errors on latest osx. Any help appreciated.

tjmac: tj$ npm -v
1.5.0-alpha-4
tjmac: tj$ npm install -g bower
npm WARN optional dep failed, continuing http-signature@~0.10.0
npm ERR! Error: ENOENT, lstat '/usr/local/lib/node_modules/bower/node_modules/insight/node_modules/configstore/node_modules/js-yaml/node_modules/argparse/index.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Darwin 13.3.0
npm ERR! command "node" "/usr/local/bin/npm" "install" "-g" "bower"
npm ERR! cwd /Users/tj/Dropbox/Development/php-mustsee
npm ERR! node -v v0.10.29
npm ERR! npm -v 1.5.0-alpha-4
npm ERR! path /usr/local/lib/node_modules/bower/node_modules/insight/node_modules/configstore/node_modules/js-yaml/node_modules/argparse/index.js
npm ERR! fstream_path /usr/local/lib/node_modules/bower/node_modules/insight/node_modules/configstore/node_modules/js-yaml/node_modules/argparse/index.js
npm ERR! fstream_type File

@iarna iarna added the support label
@smikes

Is this still a problem for you?

This looks like one of the problems caused by race conditions that were mostly eliminated in npm@2 -- the latest version is 2.3.0 and reports of these problems have dropped off substantially.

There have been a lot of improvements to npm -- especially around conflicts and race conditions during install -- since 1.5. Can you try updating your npm installation?

To update npm, run npm -g install npm@latest

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and open a new issue!)

Thanks!

@tonyjessup
@othiym23
Owner

Closing as resolved.

@othiym23 othiym23 closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.