Linter Installation Error #5761

Closed
darki73 opened this Issue Jul 22, 2014 · 3 comments

Comments

Projects
None yet
5 participants
@darki73

darki73 commented Jul 22, 2014

> execSync@1.0.1-pre install C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\copy-paste\node_modules\execSync
> node-gyp rebuild


C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\copy-paste\node_modules\execSync>node "c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bin\node-gyp.js" rebuild 

npm http GET https://registry.npmjs.org/copy-paste
npm http GET https://registry.npmjs.org/font-awesome/4.0.3
npm http GET https://registry.npmjs.org/emissary
npm http GET https://registry.npmjs.org/jshint
npm http GET https://registry.npmjs.org/lodash
npm http GET https://registry.npmjs.org/chai
npm http GET https://registry.npmjs.org/shelljs
npm http GET https://registry.npmjs.org/xregexp/2.0.0
npm http GET https://registry.npmjs.org/temp
npm http GET https://registry.npmjs.org/sinon
npm http 304 https://registry.npmjs.org/lodash
npm http 304 https://registry.npmjs.org/jshint
npm http 304 https://registry.npmjs.org/chai
npm http 304 https://registry.npmjs.org/shelljs
npm http 304 https://registry.npmjs.org/emissary
npm http 304 https://registry.npmjs.org/temp
npm http 304 https://registry.npmjs.org/sinon
npm http 304 https://registry.npmjs.org/copy-paste
npm http 304 https://registry.npmjs.org/font-awesome/4.0.3
npm http 304 https://registry.npmjs.org/xregexp/2.0.0
npm http GET https://registry.npmjs.org/property-accessors
npm http GET https://registry.npmjs.org/underscore-plus
npm http GET https://registry.npmjs.org/mixto
npm http GET https://registry.npmjs.org/execSync
npm http GET https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/underscore-plus
npm http 304 https://registry.npmjs.org/rimraf
npm http 304 https://registry.npmjs.org/mixto
npm http 304 https://registry.npmjs.org/property-accessors
npm http 304 https://registry.npmjs.org/execSync
npm ERR! Error: ENOENT, chmod 'C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\shelljs\src\to.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Иван\\.atom\\.apmrc" "install" "C:\\Users\\Иван\\.atom\\.node-gyp\\.atom\\.apm\\linter\\0.4.11\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\shelljs\src\to.js
npm ERR! fstream_path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\shelljs\src\to.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! fstream_finish_call chmod
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:305:19
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\sinon\lib\sinon\util\fake_timers.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Иван\\.atom\\.apmrc" "install" "C:\\Users\\Иван\\.atom\\.node-gyp\\.atom\\.apm\\linter\\0.4.11\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\sinon\lib\sinon\util\fake_timers.js
npm ERR! fstream_path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\sinon\lib\sinon\util\fake_timers.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\font-awesome\src\3.2.1\assets\font-awesome\css\font-awesome.min.css'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Иван\\.atom\\.apmrc" "install" "C:\\Users\\Иван\\.atom\\.node-gyp\\.atom\\.apm\\linter\\0.4.11\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\font-awesome\src\3.2.1\assets\font-awesome\css\font-awesome.min.css
npm ERR! fstream_path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\font-awesome\src\3.2.1\assets\font-awesome\css\font-awesome.min.css
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! Error: ENOENT, lstat 'C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\jshint\src\jshint.js'
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Иван\\.atom\\.apmrc" "install" "C:\\Users\\Иван\\.atom\\.node-gyp\\.atom\\.apm\\linter\\0.4.11\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\jshint\src\jshint.js
npm ERR! fstream_path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\jshint\src\jshint.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code ENOENT
npm ERR! errno 34
npm ERR! fstream_stack c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:284:26
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR! EEXIST, mkdir 'C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\chai\lib\chai\utils'
File exists: C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\chai\lib\chai\utils
Move it away, and try again. 

npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Иван\\.atom\\.apmrc" "install" "C:\\Users\\Иван\\.atom\\.node-gyp\\.atom\\.apm\\linter\\0.4.11\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\chai\lib\chai\utils
npm ERR! fstream_path C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24\node_modules\linter\node_modules\chai\lib\chai\utils\overwriteProperty.js
npm ERR! fstream_type File
npm ERR! fstream_class FileWriter
npm ERR! code EEXIST
npm ERR! errno 47
npm ERR! fstream_stack c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\fstream\lib\writer.js:171:23
npm ERR! fstream_stack c:\ProgramData\chocolatey\lib\Atom.0.115.0\tools\Atom\resources\app\apm\node_modules\atom-package-manager\node_modules\npm\node_modules\mkdirp\index.js:37:53
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm http GET https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/graceful-fs

The current directory is invalid.
npm ERR! not found: git
npm ERR! 
npm ERR! Failed using git.
npm ERR! This is most likely not a problem with npm itself.
npm ERR! Please check if you have git installed and in your PATH.
npm ERR! System Windows_NT 6.2.9200
npm ERR! command "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\bin\\\\node.exe" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "c:\\ProgramData\\chocolatey\\lib\\Atom.0.115.0\\tools\\Atom\\resources\\app\\apm\\node_modules\\atom-package-manager\\.apmrc" "--userconfig" "C:\\Users\\Иван\\.atom\\.apmrc" "install" "C:\\Users\\Иван\\.atom\\.node-gyp\\.atom\\.apm\\linter\\0.4.11\\package.tgz" "--target=0.11.10" "--arch=ia32" "--msvs_version=2013"
npm ERR! cwd C:\Users\3C8A~1\AppData\Local\Temp\apm-install-dir-114622-42592-1762r24
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.4
npm ERR! code ENOGIT
npm WARN optional dep failed, continuing execSync@1.0.1-pre
@rlidwka

This comment has been minimized.

Show comment Hide comment
@rlidwka

rlidwka Jul 22, 2014

Contributor

npm ERR! This is most likely not a problem with npm itself.
npm ERR! Please check if you have git installed and in your PATH.

I wonder, what are error messages good for if people don't read them...

Contributor

rlidwka commented Jul 22, 2014

npm ERR! This is most likely not a problem with npm itself.
npm ERR! Please check if you have git installed and in your PATH.

I wonder, what are error messages good for if people don't read them...

@darki73

This comment has been minimized.

Show comment Hide comment
@darki73

darki73 Jul 23, 2014

The thing is, I've re-installed both "Git for Windows" and "Git Utils", also I've installed latest Node.js and Python 2.7.8 as it recommended in installation guide. So i'm sure that everything is correct in terms of PATH and other things

darki73 commented Jul 23, 2014

The thing is, I've re-installed both "Git for Windows" and "Git Utils", also I've installed latest Node.js and Python 2.7.8 as it recommended in installation guide. So i'm sure that everything is correct in terms of PATH and other things

@robertkowalski

This comment has been minimized.

Show comment Hide comment
@robertkowalski

robertkowalski Aug 9, 2014

Member

@darki73 does git --version on the console where you type in the npm command give you some output?

Member

robertkowalski commented Aug 9, 2014

@darki73 does git --version on the console where you type in the npm command give you some output?

@isaacs isaacs closed this Aug 26, 2014

@othiym23 othiym23 added the support label Sep 21, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment