tunneling socket could not be established, sutatusCode=407 #5793

Closed
vinhvien2005 opened this Issue Jul 25, 2014 · 3 comments

Projects

None yet

4 participants

@vinhvien2005
When I install socket.io with command : npm install socket.io
I have get error 
ERR! Error: tunneling socket could not be established, sutatusCode=407
ERR!     at onConnect (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\request\tunnel.js:148:19)
ERR!     at Array.0 (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\request\tunnel.js:132:7)
ERR!     at EventEmitter._tickCallback (node.js:190:38)
ERR! You may report this log at:
ERR!     <http://github.com/isaacs/npm/issues>
ERR! or email it to:
ERR!     <npm-@googlegroups.com>
ERR! 
ERR! System Windows_NT 6.2.9200
ERR! command "C:\\Program Files (x86)\\nodejs\\\\node.exe" "C:\\Program Files (x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "socket.io"
ERR! cwd C:\Users\vien.nguyenvan
ERR! node -v v0.6.19
ERR! npm -v 1.1.24
ERR! code ECONNRESET
ERR! message tunneling socket could not be established, sutatusCode=407
ERR! errno {}

How I can fixed and install socket.io.
Thanks.

@KenanY
Member
KenanY commented Jul 25, 2014

Node.js 0.6 is a couple years old and is no longer supported. You should upgrade to the latest stable version at nodejs.org

@vinhvien2005

Thanks I try to upgrade to the latest stable version.

@iarna iarna added the support label Sep 17, 2014
@othiym23
Contributor

Closing as abandoned. @vinhvien2005, if you ever come back to this, read this troubleshooting guide on how to get up to date with node and npm.

@othiym23 othiym23 closed this Sep 22, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment