Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

issue with grunt installation #5794

Closed
prasoons opened this Issue Jul 25, 2014 · 3 comments

Comments

Projects
None yet
4 participants

Hello
I am getting issue as below while installing Grunt on my window 7. Can you help us

$ npm install grunt
npm ERR! Error: SELF_SIGNED_CERT_IN_CHAIN
npm ERR!     at SecurePair.<anonymous> (tls.js:1365:32)
npm ERR!     at SecurePair.emit (events.js:92:17)
npm ERR!     at SecurePair.maybeInitFinished (tls.js:977:10)
npm ERR!     at CleartextStream.read [as _read] (tls.js:469:13)
npm ERR!     at CleartextStream.Readable.read (_stream_readable.js:323:10)
npm ERR!     at EncryptedStream.write [as _write] (tls.js:366:25)
npm ERR!     at doWrite (_stream_writable.js:226:10)
npm ERR!     at writeOrBuffer (_stream_writable.js:216:5)
npm ERR!     at EncryptedStream.Writable.write (_stream_writable.js:183:11)
npm ERR!     at write (_stream_readable.js:585:24)
npm ERR!     at flow (_stream_readable.js:594:7)
npm ERR!     at Socket.pipeOnReadable (_stream_readable.js:626:5)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "c:\\Program Files\\nodejs\\node.exe" "c:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "
install" "grunt"
npm ERR! cwd U:\
npm ERR! node -v v0.10.29
npm ERR! npm -v 1.4.14
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     U:\npm-debug.log
npm ERR! not ok code 0
Contributor

othiym23 commented Jul 26, 2014

Are you using a proxy to connect to the internet? Do you need to tell npm about the CA certificate for the proxy?

@iarna iarna added the support label Sep 17, 2014

Contributor

smikes commented Dec 13, 2014

Is this still a problem for you?

There have been a lot of improvements to npm since 1.4.14. Can you try updating your npm installation?

To update npm on Windows, follow the instructions here: https://github.com/npm/npm/wiki/Troubleshooting#upgrading-on-windows

We are trying to clean up older npm issues, so if we don't hear back from you within a week, we will close this issue. (Don't worry -- you can always come back again and open a new issue!)

Thanks!

Contributor

othiym23 commented Dec 22, 2014

Closing as abandoned.

@othiym23 othiym23 closed this Dec 22, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment